body::esri:inputMask with (999)999-9999 on Android

177
2
Jump to solution
10-20-2020 05:09 PM
BKS
by
New Contributor III

Using version 3.10 of ArcGIS Survey Connect, I've used body::esri:inputMask of (999)999-9999 to ensure the format for phone number input.

On iOS and Windows field app all works fine.  However, using Android field app, when entering the phone number, after typing the 3rd digit it disappears after entry. It's hard to explain but entering 10 digits will not enter a valid phone number format as it does on iOS and Windows.  It's broken to the point where it is not usable.

Hate to not use this formatting. 

Any other experience same?  Any workaround?

Thanks, brian

Reply
0 Kudos
1 Solution

Accepted Solutions
ZacharySutherby
Esri Contributor

Hello Brian Schwarz‌, 

Thank you for reaching out with this issue! I have been able to reproduce the behavior on our Galaxy Tab Active and have logged an issue on our end. 

As a workaround if you set the appearance to the question as 'numbers' the behavior is not reproducible. We have seen some strange issues with the Android keyboard and I believe this would fall under one of those scenarios. 

I would suggest logging a case with Esri Technical Support as they will be able to log an official BUG that you can track the status of as it progresses through it's lifecycle. 

Thank you, 

Zach

View solution in original post

Reply
0 Kudos
2 Replies
ZacharySutherby
Esri Contributor

Hello Brian Schwarz‌, 

Thank you for reaching out with this issue! I have been able to reproduce the behavior on our Galaxy Tab Active and have logged an issue on our end. 

As a workaround if you set the appearance to the question as 'numbers' the behavior is not reproducible. We have seen some strange issues with the Android keyboard and I believe this would fall under one of those scenarios. 

I would suggest logging a case with Esri Technical Support as they will be able to log an official BUG that you can track the status of as it progresses through it's lifecycle. 

Thank you, 

Zach

View solution in original post

Reply
0 Kudos
BKS
by
New Contributor III

Hello Zachary,

Thanks for confirming the issue.

And many thanks for the work-around. This seems to work.

Regards, Brian

Brian K. Schwarz Consulting Inc., Ottawa, Canada

Reply
0 Kudos