Bi-lingual Survey: ArcGIS Survey123 Connect "preview" displays in second language

88
2
Jump to solution
a week ago
Regular Contributor

I have a bi-lingual survey (English and Spanish) that is working well.  However, the ArcGIS Survey123 Connect preview window and its menu items displays in Spanish.  I would much prefer to see it in English... 

The only way I see to control what language shows up in the preview window is to set the default language to "English (en)".  But when I do that, then using a Spanish link to launch the Survey https://survey123.arcgis.com/share/c59798bbb241466f9384fd3829077579?lang=es launches in English, not Spanish.

What am I missing here?

Bi-lingual_Issue.PNG

Jay
Washoe County GIS
Tags (2)
Reply
0 Kudos
1 Solution

Accepted Solutions
Esri Frequent Contributor

Hi @JayJohnsonWashoeCounty,

What you are seeing is currently the expected behaviour. When the form locale is changed, the other UI components of the app will also change while that form is in use, to make it easier for the user to read the rest of the UI in their preferred language. This is mainly designed for the field app, and works well in that case.

The problem you are seeing is with Connect, we have an internal issue in our backlog to seperate this form local behaviour to be different between the field app and Connect, however currently it is not possible as they share the same form rendering and display logic. I would suggest you raise this as support enhancement via Esri Support, and we can link it up to our internal issue. This will help prioritise this issue.

Regards,

Phil.

View solution in original post

2 Replies
Esri Frequent Contributor

Hi @JayJohnsonWashoeCounty,

What you are seeing is currently the expected behaviour. When the form locale is changed, the other UI components of the app will also change while that form is in use, to make it easier for the user to read the rest of the UI in their preferred language. This is mainly designed for the field app, and works well in that case.

The problem you are seeing is with Connect, we have an internal issue in our backlog to seperate this form local behaviour to be different between the field app and Connect, however currently it is not possible as they share the same form rendering and display logic. I would suggest you raise this as support enhancement via Esri Support, and we can link it up to our internal issue. This will help prioritise this issue.

Regards,

Phil.

View solution in original post

Regular Contributor

Thanks - good info. 

I did find a menu option within Connect to switch languages within the designer preview "on the fly", which works well enough for what I need.

Jay
Washoe County GIS