App Studio 4 beta build has the wrong app icon when published to App Store

133
3
08-26-2019 11:48 AM
Highlighted
Occasional Contributor II

Hello,

Ismael Chivite

Erwin Soekianto

I used to work with App Studio 3, and was successfully publishing customized apps based on Survey123 template to App Store.

Then I switched to App Studio beta version (4), because I needed an updated Survey123 template. And since then when I upload the build to App Store through XCode App Loader, the app icon is Survey123 original icon even though I changed it a while ago!

I tried to build in App Studio with Windows, Mac, with App Studio 3 and App Studio 4 - the result is that app created with App Studio 4 keeps the original Survey 123 icon! Everything except this works fine, the app itself is correct.

Do you have any thoughts or ideas why it is happening?

Thanks

Reply
0 Kudos
3 Replies
Highlighted
Occasional Contributor II

Ok, so I deleted all Survey 123 icons from the app folder, and then tried to build again, and it did not work, cause it could not find those images, even though they were not used anywhere in the app (again - I changed app icon with my picture). So then I renamed my pics with survey123 icon names "appicon.png" and then when I built it and loaded to app store, it finally worked. I don't know what it is, may be app studio beta version bug, cause I never had this issue before.

Reply
0 Kudos
Highlighted
Esri Regular Contributor

Yulia, 

I am glad that this is working for you, we are going to investigate this issue you described internally. 

Did you make sure to upload your app after making changes to your app before doing Cloud Make? 

The Cloud Make will take the copy of your app from the uploaded version, not the version that is in your computer. So for example, if you change the app icon in the app, you need to upload the app first, then do Cloud Make to see the changes in the build app. 

cc: AppStudio for ArcGIS

Thank you,

Erwin. 

Reply
0 Kudos
Highlighted
Occasional Contributor II

Hi Erwin,

Thank you for your response! Yes, I uploaded the version of the app to the cloud each time before building it.

Thank you,

Yulia

Reply
0 Kudos