all xform formatting breaks when I place a calculation in a Select_one question.

347
7
Jump to solution
05-04-2018 02:00 AM
LeeBerryman
New Contributor III

I was so happy to hear that calculations are supported on select_one questions, but I'm facing a problem in implementing this functionality.  I have a work flow that is using pull data calculations to populate a text field.  Because I have a question later that is a select_one question that is the same data I don't want to ask the end user for the same information again.  I want the select_one question to auto populate.  When I place the calculation "${text}" in the calculation column for the select_one question all of my xform appearance, relevant, and data calculations break.

I can't just skip the select_one question, because the pulldata on the {text} field is dependent on an online workflow and we have many users that don't have internet in their field context, and there is a later question that filters based on the response in the select_one question.  Am I trying to implement a workflow that was not envisioned in the new calculation capabilities in select_one questions or am I typing in the calculation wrong?

Reply
0 Kudos
1 Solution

Accepted Solutions
BrandonArmstrong
Esri Regular Contributor

Hi Lee,

I'm wondering if the appearance type for the select_one question that causes issues is set to 'autocomplete'?  If so, please try to assign a different appearance type, say 'minimal' and see it the functionality of your calculation and relevant's return.

Regards,

Brandon

View solution in original post

Reply
0 Kudos
7 Replies
BrandonArmstrong
Esri Regular Contributor

Hi Lee,

I'm wondering if the appearance type for the select_one question that causes issues is set to 'autocomplete'?  If so, please try to assign a different appearance type, say 'minimal' and see it the functionality of your calculation and relevant's return.

Regards,

Brandon

View solution in original post

Reply
0 Kudos
LeeBerryman
New Contributor III

Yes Brandon auto complete is what the appearance is set to.  I'll check if turning that off makes the calculation work.  I have several hundred choices in the pull down so autocomplete is desirable.

Reply
0 Kudos
LeeBerryman
New Contributor III

Brandon,  I took the autocomplete off on the particular select_one questions that have the calculations.  There is still autocomplete on other select_one questions that do not have calculations and it’s working. 

Reply
0 Kudos
BrandonArmstrong
Esri Regular Contributor

Thank you for sharing your results, Lee.

At the moment, the autocomplete appearance is not supported with select_one questions, however, we do look to add support for it in the future.  The behavior that you reported is an unintended consequence of applying the autocomplete appearance to a select_one question with a calculation, and it has been entered into our internal backlog for review.  I have gone ahead and added a note regarding your experience.

Regards,

Brandon

Reply
0 Kudos
AndrewPadilla
New Contributor III

Hi Brandon, 

Has this been resolved? I am having a similar issue with a select_one question that has a calculation (pulldata) and predictive text appearance.  The pulldata function selects the correct data however it is not selected as the answer (see attached image). After reading this post, I changed the appearance to minimal compact but the result was the same- the correct data is pulled but the answer is not selected. Is it possible to have a pulldata function with a select one question and have the data selected? Thank you for your time. 

AndrewPadilla_0-1607103916012.png

 

 

Regards,

Andy

Reply
0 Kudos
BrandonArmstrong
Esri Regular Contributor

Hi Andy,

Yes, the issue related to calculations being applied to select one questions with auto complete appearance was resolved with Survey123 v.3.1.

It sounds like you are encountering this issue when utilizing the predictive text appearance.

My suggestion would be to create a new post with details including the v. of Survey123 you are seeing this behavior (Survey123 Connect and Survey123 Field App), the OS (Windows/Android/iOS), and a sample XLSForm with external pulldata sheet included.  This way someone can take a look with the information that will likely be needed.

Best,

Brandon

Reply
0 Kudos
AndrewPadilla
New Contributor III

Hi Brandon,

Thank you for your response. Since, it was not imperative to use predictive text, I ended up using minimal compact as a work around.