About the setting to make the _fieldworler layer inaccessible to public users.

141
1
03-29-2021 09:28 PM
Labels (1)
yuki-ozawa
New Contributor

Public users can view the _fieldeworker layer unless you create a survey form in Survey123 and select Only add new records in the collaborative What can submitters do ?.

This phenomenon does not occur with newly created questionnaires. Do you know what is causing this?

Also, how can I set to deny access from public user?

setting-min.png

0 Kudos
1 Reply
jcarlson
MVP Regular Contributor

To deny access, change the sharing settings on the Form item and the underlying Feature Layer to something besides Public. You can update both from the Content page, but you can also change the sharing settings from the form ("Who can submit to this survey?")

The fieldworker layer is just a View Layer of the main. I have noticed that some surveys created more recently will not automatically create this view, but I am not certain as to why. It may be related to a recent update of Survey123, perhaps?

- Josh Carlson
Kendall County GIS
0 Kudos