Option to suppress "position source closed error" in Survey123 app

1848
10
08-27-2019 01:05 PM
Status: Open
New Contributor III

We can suppress alerts related to having location services disabled in surveys themselves, but it would be nice to also suppress this screen on startup:

We use Survey123 for a number of data collection workflows where the device's location is unimportant and those surveys are usually filled out on desktop computers that have location services disabled. Users find the above error (which appears every time the app is opened) confusing or annoying, especially for new or infrequent users.

Tags (1)
10 Comments

Hi M Taft-Ferguson  

 

It depends on the version you have of the app, for example, I leave you some updates:

  • Update of 09/26/2019: Fixed an error that caused the geopoint calculations that use values in a main layer not to be applied after the first repetition.
  • In the update 01/31/2019 connect 3.2.196: Various corrections of location and internationalization errors and improvements have been made.
  • Update of 11/21/2017 version 2.5.44. when using a Bluetooth R1 Trimble GNSS receiver

 

The link: Novedades de Survey 123

Other link: What's new in Survey123 

 

Hope this can help you.

Hi Juan,

Forgive me if I misunderstand, but I have the most recent version of the desktop app (3.7.57) and still get the error every time I open the app:

I have users reporting the exact same complaint. And I get their point. Some of our inspection forms take a very long time to fill out because they involve test-running mechanical equipment etc.; you don't want to have the GPS draining your device battery during that entire time. But every time you wake your device or you switch back from a different app to the Survey123 app you have to hit Ok to this "Stupid notice" - I'm quoting our field crew here. Not a happy user experience, Esri!

Anyone know if an official bug or enhancement request been logged for this?

I, too, am getting the "Position source closed error" when on my Survey 123 Connect forms. I have been searching for a fix but, at this time, am unable to find one.

Hi.  I wanted to share that we are also getting reports of some users suddenly getting this error.  Does anyone know if we should be concerned about data entry or upload issues?

Hi, I am also getting an error message "Position source closed error" for geopoints (respondents must enter in a zip code). Not sure if it was me doing something incorrectly but it seems it may be an update issue?  position source closed error

All,

I only started receiving this when I got a new pc. It has to do with your location services being turned on. As soon as my location was enabled, this message went away. I would recommend making sure your location is turned on, on the device you are using.

Our IT has disabled location services for almost all devices for security reasons, and as mentioned above, device location is unimportant for many surveys that our users complete. In our case, we need an option to suppress the error, because we will not/cannot turn location services on and because the error does not convey any relevant information for our workflows.

I'm flooded with help desk call because of this. As others have mentioned, most organizations disable location services on desktops and laptops. What is ESRI's specific reasoning for not allowing users to surpress this warning in settings?

Does anyone know if this was resolved in the latest 3.10 release? My users hate this too, and it would be really nice to turn off.