Allow Survey123 feature report templates to work with Integrated Windows Authentication (IWA) in ArcGIS Enterprise

676
3
03-17-2021 07:45 AM
Status: Open
Labels (1)
StaceyDudenhoeffer
New Contributor II

Currently, Survey123 report templates have a limitation.  Printing using report templates does not work when Integrated Windows Authentication (IWA) is configured with ArcGIS Enterprise Portal. 

We have several use cases for printing reports from hosted Survey123 feature services.  The reports are simple and a great visual for our employees to display submitted surveys.  We currently have a public facing ArcGIS Enterprise deployment, but we use IWA.  We are not able to utilize report templates because of the limitation.  Is it possible to add this capability in the future?

3 Comments
AdrianDoss

We have the same issue, in fact I had to inform one of my co-workers yesterday that it wasn't possible to do feature reports for surveys hosted on our own portal with IWA authentication. I think I read that it may be possible if the Survey123 website is installed onto the portal server but would need ESRI to confirm this.

I have brought this up before here

I have had to resort to roll-your-own reports using Python, Microsoft Word templates, and the API, which is far from convenient. 

Survey123 is a great product but with reporting on portal/IWA not supported and various issues such as poor barcode/QR code reading, I think ESRI should focus on getting all features working whether on Enterprise/Portal or AGOL.

SandyStroz

We have the same issue due to our portal using IWA authentication.  

DeanMacbain

Hi ESRI,

Has there been any progression with this known limitation where the report server cannot be reached when Enterprise portal is IWA configured?

I am starting to get good buy in at our company but feel like I am selling half a product.

Is there anything in the timeline?