StoryMap Guided Tour not responding to Review filtering Survey123

386
1
Jump to solution
12-09-2022 01:23 AM
Labels (2)
RoisinBurke
New Contributor

Hi am working on a project featuring crowdsourcing, For this purpose we are following the guidelines suggested in the Blogpost "Combining Crowdsourcing data and Arcgis Storymaps" . At one point the post is suggesting that in order to prevent the results from going live without a check, you can add "Review is Accept" as a filter, which will hide the data from the public until such time the submission is approved. 

I have followed the instructions to the best of my abilities but when I implement the Guided Tour map in Storymap is shows me all results and no filtering. If I implement a map it filters but I cannot see how to dress the map with the images uploaded and it did not seem to dynamically update. 

So my query is in 2 parts. 

1. Is there a way I can get the filtered results to be recognised by Guded Map tour in Storymap? (preferred option)

2, How can I make the images appear in a map and do so automatically when a new feature appears?

I am new to the system so learning curve is steep here

Thanks

 

 

0 Kudos
1 Solution

Accepted Solutions
JenniferAcunto
Esri Regular Contributor

I suspect you are using the Map Tour block and selecting 'Start with a Feature Service'. You will need a filtered view of your survey layer to get your map tour to only show approved records. 

Start at the Item Details page for your survey layer. Make sure you are using the Hosted Feature Layer and not one of the views that survey automatically creates.

2022-12-09_6-47-19.png

 

Click Create View Layer

2022-12-09_6-37-12.png

 

Go through the steps of creating a view. Ensure you add a filter to your view definition so only your approved records are visible.

2022-12-09_6-37-52.png

 

Now you can return to your StoryMap and create your map tour using the view layer you just created. Note that you need to have at least one point visible in your view layer before map tour will let you pick that layer, so you may need to approve a dummy point while setting up your StoryMap. You can always go back and unapprove or delete it later and it will be removed from your StoryMap.

- Jen

View solution in original post

1 Reply
JenniferAcunto
Esri Regular Contributor

I suspect you are using the Map Tour block and selecting 'Start with a Feature Service'. You will need a filtered view of your survey layer to get your map tour to only show approved records. 

Start at the Item Details page for your survey layer. Make sure you are using the Hosted Feature Layer and not one of the views that survey automatically creates.

2022-12-09_6-47-19.png

 

Click Create View Layer

2022-12-09_6-37-12.png

 

Go through the steps of creating a view. Ensure you add a filter to your view definition so only your approved records are visible.

2022-12-09_6-37-52.png

 

Now you can return to your StoryMap and create your map tour using the view layer you just created. Note that you need to have at least one point visible in your view layer before map tour will let you pick that layer, so you may need to approve a dummy point while setting up your StoryMap. You can always go back and unapprove or delete it later and it will be removed from your StoryMap.

- Jen