Issues with April update

1701
12
04-09-2020 04:07 PM
BryanHemmer
Occasional Contributor III

I hate to be the one to rain on parades. Especially when it comes to the hard work put it to make something better such as the story navigation because I love this and have been looking forward to this for a while now. But, I have ran into some issues with the April update. I do have one major issue that needs to be addressed very soon. The issues I'll be addressing in this post has to do with story navigation and Collections. First, please don't take any of this and think I'm not happy because I am and really excited about updates you made, especially the navigation capability. Just some things that need to be pointed out that are issues.

I have made videos to aid in explaining what I am seeing. Also, all of these story maps are public and I am attaching links to them as well. These issues are based off my most current project so I am not sure how the update has affected previous story maps I have made. One thing to note is that even though these are public they are drafts and any figures, tables, estimates, maps, etc., are subject to change.


1) Issue in Collections (DRAFT Minnesota Forests, 2018 Collections) - see video 1_collections.mp4
- From within Collections, when I select the first story map I get the message "An unexpected error has occurred".


2) Issue with navigation #1 (DRAFT Minnesota 2018 - Introduction) - see video 2_introduction_notNavigating.mp4
- Navigating the first four sections work fine. However, when I select the Background section it will navigate to the section, but does not "highlight" heading in nav bar.

- I'm also not able to navigate to Guide to Forest Inventory and Major Components sections at all.


3) Issue with navigation #2 (DRAFT Minnesota 2018 - Health Indicators) - see video 3_healthIndicators_notNavigating.mp4
- Navigating the first three sections work fine.
- Issue I run into is when I navigate to Invasive Plant Species section. Selecting heading in the nav bar brings user to text just above section. It also does not "highlight" heading in nav bar.
- The next two sections work when navigating.
- When I navigate to the Urbanization and Fragmentation of Forest Land section it will go, but it does not "highlight" heading in nav bar.

4) MAJOR Issue! (DRAFT Minnesota 2018 - Socioeconomics) - see video 4_socioeconomics.mp4
- I am no longer able to edit this story map since I tried to enable navigation. I opened the story map original so I could apply the new navigation capability. After I selected the toggle I received "An unexpected error has occurred".

- I am able to open the story map but every time I try to enter builder mode I receive the error. So now I'm kind of stuck.


So this is what I'm seeing right now. In case you need to know or if it matter I am using Mozilla Firefox 75.0 (64-bit).

0 Kudos
12 Replies
MiaMassicotte
Occasional Contributor

Many times I run into "an unexpected has occurred", but as the last point in the workflow - i.e. last message during the 'save and publish' changes sequence.  

Using Safari (13.1),  I got into the workflow of doing my changes, and waiting for the storymap "saving..." and "you have unpublished changes".  Then I would clear Safari cookies and reload the page to view and/or exit.    

I had the sense that it might have something to do with the way ArcGIS logins work, and the way my Safari window and tab preferences are set up, but I have cycled through practically every iteration and this is what I have settled on for the time being:

If anyone has suggestions for optimal settings for using Safari and logging into ArcGIS, and window/tab settings, I would welcome them.

arcgis storymap safari browser

Mia

0 Kudos
OwenGeo
Esri Frequent Contributor

Hi Bryan - thanks for the detailed info. I know someone is following up with you to get these issues worked out.

Mia -- we'll look into that issue you mentioned as well. Does it happen when publishing any story, or just some? I'm on the same version of Safari and can't reproduce that issue.

Owen Evans
Lead Product Engineer | StoryMaps
0 Kudos
MiaMassicotte
Occasional Contributor

It has happened with all of my stories in the new Storymaps that I create using my public account. I have to clear cookies a lot, and the application doesn't exit cleanly. 

#Safari browser #arcgis story maps

0 Kudos
BryanHemmer
Occasional Contributor III

Owen Evans

A colleague's app is throwing an error after he turned on the nav bar like mine did and is locked out of builder mode. I shot an e-mail to Aravind.

0 Kudos
OwenGeo
Esri Frequent Contributor

Thanks Bryan -- we're looking to deploy a patch today or tomorrow to address this issue.

Owen Evans
Lead Product Engineer | StoryMaps
0 Kudos
BryanHemmer
Occasional Contributor III

Do you know if the patch will fix ones that are broke now? I told my guy to just sit tight because he is afraid of making it worse.

0 Kudos
OwenGeo
Esri Frequent Contributor

Yes, after the patch is deployed you should be able to open stories affected by this issue as expected. I'll update this thread after the patch is deployed.

Owen Evans
Lead Product Engineer | StoryMaps
0 Kudos
OwenGeo
Esri Frequent Contributor

The patch has been deployed. You should be able to open the broken stories in builder and not get the error anymore.

Owen Evans
Lead Product Engineer | StoryMaps
BryanHemmer
Occasional Contributor III

Thanks Owen!

0 Kudos