Issue with StoryMaps on a Raspberry Pi

503
2
Jump to solution
02-18-2021 09:43 PM
AndrewRitchie
New Contributor III

This might be an odd use case.

I'm trying to load a StoryMap onto an office display screen (TV on the wall), powered by a raspberry pi.

The pi opens chromium browser on boot, and loads 3 pages into tabs, and then cycles through the tabs every 15 seconds.

When loading a StoryMap, chromium (and tested with firefox-esr) will only load the placeholder image for the cover page, and will not download the fully rendered image. 

Using Chrome dev tools on my desktop, seems to show that the image should load in two parts:

AndrewRitchie_0-1613713093123.png

However, on the pi, the blob doesn't appear to be triggered - I can't see any errors.

Is there any reason why StoryMaps wouldn't be working on a pi - are there any extensions I might need to enable? 

 

Cheers

Andrew

Tags (2)
0 Kudos
1 Solution

Accepted Solutions
AndrewRitchie
New Contributor III

Rtfm: I expect i may need to enable webGL support. :crossed_fingers:

Solution: In the end I had to make sure Chromium browser was up to date, and enable OpenGL per: https://raspberrypi.stackexchange.com/questions/83113/webgl-does-not-work-properly-on-raspberry-pi-c...

  1. use raspi-config to enable OpenGL (Full KMS)
  2. remove "--disable-gpu-compositing'' from /etc/chromium-browser/customizations/00-rpi-var

 

View solution in original post

2 Replies
AndrewRitchie
New Contributor III

Here's a sample of what loads for the cover page. The blurred image is the placeholder image (20px * 9px) massively blown up to fit the area. 

AndrewRitchie_0-1613713692110.jpeg

 

0 Kudos
AndrewRitchie
New Contributor III

Rtfm: I expect i may need to enable webGL support. :crossed_fingers:

Solution: In the end I had to make sure Chromium browser was up to date, and enable OpenGL per: https://raspberrypi.stackexchange.com/questions/83113/webgl-does-not-work-properly-on-raspberry-pi-c...

  1. use raspi-config to enable OpenGL (Full KMS)
  2. remove "--disable-gpu-compositing'' from /etc/chromium-browser/customizations/00-rpi-var