I can't change the Analytics/GDPR consent message in a Story Map

756
6
Jump to solution
05-01-2023 12:43 PM
Labels (2)
AurelieShapiro
Occasional Contributor II

I created duplicate story maps for different languages - but the Google analytics ID and consent message under Analytics in the Sharing settings seems stuck on what I had in the original story map.

I have tried deleting changing, saving, publishing - but it always seems to go back to the original message. How can I change the Google Analytics to different data streams and adapt the message in my duplicate story maps?

 

original story map: https://storymaps.arcgis.com/stories/08c4d90f9caf4d6ab9e5bbdb21f222fa

translation: https://storymaps.arcgis.com/stories/3ebe8d3b300d452a839c4ed37b9a7895 

settings.jpgstory_map_ES.jpg

 

0 Kudos
1 Solution

Accepted Solutions
OwenGeo
Esri Notable Contributor

@jkarmon -- If you would like to fix the issue now and not wait for the fix, you can follow these steps...

  1. Open the story in the story builder
  2. Go to Story settings > Analytics tab
  3. Ensure information is still correct
  4. Click Save
  5. Publish the story 

Note that if you have other unpublished changes, those will also be published.

Owen Evans
Lead Product Engineer | StoryMaps

View solution in original post

6 Replies
OwenGeo
Esri Notable Contributor

@AurelieShapiro -- Thank you for reporting this problem with updating the analytics settings, and I apologize that you are being affected by it. We are aware of this issue and are working on a fix that we should be deploying in the next few days. We will update this thread when there is additional information.

Owen Evans
Lead Product Engineer | StoryMaps
OwenGeo
Esri Notable Contributor

We are in final testing and plan to deploy the fix for this issue tomorrow evening, 5/4.

Owen Evans
Lead Product Engineer | StoryMaps
0 Kudos
OwenGeo
Esri Notable Contributor

A fix for this issue have been deployed. Please let us know if you are still experiencing this problem.

Owen Evans
Lead Product Engineer | StoryMaps
0 Kudos
jkarmon
New Contributor III

Is there any way to STOP this message from showing if you have enabled Google Analytics but didn't set a message?  (It didn't use to show before, and now it's making users nervous and opting to close out our story map).  

https://storymaps.arcgis.com/stories/f6a5aa690a754dda8dba8addcc718a07

 

0 Kudos
OwenGeo
Esri Notable Contributor

@jkarmon -- This is a bug that affects a small number of stories that started using Google Analytics during a specific time. It will be fixed in an update coming next Weds evening. After that the message should stop appearing.

I apologize you were impacted by this issue.

Owen Evans
Lead Product Engineer | StoryMaps
OwenGeo
Esri Notable Contributor

@jkarmon -- If you would like to fix the issue now and not wait for the fix, you can follow these steps...

  1. Open the story in the story builder
  2. Go to Story settings > Analytics tab
  3. Ensure information is still correct
  4. Click Save
  5. Publish the story 

Note that if you have other unpublished changes, those will also be published.

Owen Evans
Lead Product Engineer | StoryMaps