Rerunning batched raster tools - output raster greyed out

438
7
08-30-2017 06:06 AM
New Contributor II

I'm trying to rerun a batched raster analysis (point statistics). However, when I open the batch grid, the output raster field is greyed out/inactive except for the first line. Anyone know if this is a bug or have a workaround?

Reply
0 Kudos
7 Replies
MVP Esteemed Contributor

sounds like the results already exist and a new input is required before you can continue

Reply
0 Kudos
New Contributor II

To me, one of the great things about the results tab is the ability to run tools over and over, trial and error. Change some settings, change the input data etc. This works fine with vector data, both single and batched processes. In batched raster operations however, this does not seem to work.

Reply
0 Kudos
New Contributor II

I have checked the overwright output features box, and I have tried deleting all outputs before trying rerun. No luck.

Reply
0 Kudos
MVP Esteemed Contributor

so obviously, nothing will be overwritten if it is in arcmap or pro... that leaves a few functions that I know about that will not be overwritten regardless of the settings.  In cases like that, save, close and restart arc-whatever is often what is needed... 

Reply
0 Kudos
New Contributor II

This is in ArcMap. All (well, most) outputs will should be overwritten with said settings. And I have tried the close/restart solution.

Reply
0 Kudos
MVP Esteemed Contributor
MVP Esteemed Contributor

I believe that Model Builder iterators are often better solution than batch for many one-off workflows like this. I'd look into it.