A note about Qt 5.9.0

246
0
08-02-2017 09:38 AM
Labels (1)
EricBader
Regular Contributor II
0 0 246

We hope you are finding ArcGIS Runtime SDK 100.1 for Qt (Update 1) to be useful and productive for you. As always, please continue to use GeoNet and share your feedback. We're here to help you in any way we can.

Now, regarding support for Qt 5.9.0:

During our certification of Update 1 we discovered a critical Qt 5.9.0 bug specific to iOS and macOS in the Qt 5.9.0 final release. All https requests report an SSL handshake error so not even Esri basemaps will draw on iOS or macOS devices. There is no viable workaround for this issue that we are aware of that will ensure the security of your applications. You can read the bug report (QTBUG-61053) here, which indicates that it was fixed in 5.9.1. Also, you will encounter compilation errors using 5.9.0 Qt Creator (4.3.0) on El Capitan v.10.11.16 when compiling any of the Esri template projects.

In light of these issues, we strongly advise that you avoid using the Qt 5.9.0 for development with the ArcGIS Qt SDK. Instead, use Qt 5.9.1. Keep in mind, ArcGIS Runtime SDK 100.1 also supports Qt 5.6.2 and Qt 5.8.

Please let us know if you have any questions. Thank you.

The ArcGIS Runtime SDK for Qt Team

About the Author
Product Manager for ArcGIS Runtime SDKs - Java, Android, Qt