Windows 10 Connect GPS

3077
3
Jump to solution
01-27-2016 06:17 AM
CeyhunYilmaz
New Contributor III

Hi,

I have worked with Windows 10 OS for three weeks . There  is no problem except gps (to get my location). I tried with Arcgis samples apps (Qt,Qml 10.2.6) but none of them works succesfully. Additionally this component (positionDisplay etc) crashes applications.

How  can i solve this problem ?

Thanks.

0 Kudos
1 Solution

Accepted Solutions
LucasDanzinger
Esri Frequent Contributor

Hi Ceyhun-

Windows 10 was not yet released when we released our 10.2.6 SDK, so it is not listed as a supported platform under our system requirements - System requirements—ArcGIS Runtime SDK for Qt | ArcGIS for Developers

With that said, we are aware of the issue, and will be fixing this (and bringing in full support for Windows 10) in an upcoming release.

Thanks,

Luke

View solution in original post

0 Kudos
3 Replies
LucasDanzinger
Esri Frequent Contributor

Hi Ceyhun-

Windows 10 was not yet released when we released our 10.2.6 SDK, so it is not listed as a supported platform under our system requirements - System requirements—ArcGIS Runtime SDK for Qt | ArcGIS for Developers

With that said, we are aware of the issue, and will be fixing this (and bringing in full support for Windows 10) in an upcoming release.

Thanks,

Luke

View solution in original post

0 Kudos
PaulHaakma
Regular Contributor

Hi Ceyhin

Interesting to hear that - we had the exact same thing happen when using the earlier beta versions of App Studio, but then around the last beta version the issue of GPS location (positionSource etc) crashing Win 10 seemed to go away. So my assumption was that something had already been 'fixed' but maybe that's not the case.

Note also though, that we have seen issues with a particular model of PC (Panasonic Toughbook) that crashes on the same issue, and they are running Win 7. That might not have any relevance to your situation but it's worth mentioning that potentially it might not be just the OS.

See my other Geonet post at link below.

Setting PositionSource to active crashes app on Panasonic ToughBook running Win 7

Regards,

-Paul

0 Kudos
LucasDanzinger
Esri Frequent Contributor

Paul-

Good catch. Can't slip anything past you guys! AppStudio already picked up the fix, and released it in either one of the last betas or for their final. We have the fix locally, we just have yet to release it with the SDK! Our last release of the SDK was in May of 2015.

Hope this clarifies.

-Luke