g++: error: /FS: No such file or directory

2230
1
03-20-2017 09:13 AM
ShaLi
by
New Contributor

Hi,

I use the ArcGIS Runtime 100 Qt Quick c++ app  template to create a project. But It shows the /FS error when I build it. I have not write a line in the new project. So it must be my wrong configuration. But I don't know how to fix it. This is my post Installer configuration. The IDE is Qt Creator 5.8.

when I build. The message is like this below.

22:32:27: 为项目demo320执行步骤 ...

22:32:27: 配置没有改变, 跳过 qmake 步骤。

22:32:27: 正在启动 "D:\Qt\Tools\mingw530_32\bin\mingw32-make.exe"

D:/Qt/Tools/mingw530_32/bin/mingw32-make -f Makefile.Debug

mingw32-make[1]: Entering directory 'E:/programing/c++/qt/build-demo320-Desktop_Qt_5_8_0_MinGW_32bit-Debug'

g++ -c -pipe -fno-keep-inline-dllexport -g -std=gnu++11 /FS -frtti -Wall -Wextra -fexceptions -mthreads -DUNICODE -DQT_QML_DEBUG -DQT_OPENGL_LIB -DQT_WIDGETS_LIB -DQT_QUICK_LIB -DQT_GUI_LIB -DQT_XML_LIB -DQT_QML_LIB -DQT_NETWORK_LIB -DQT_POSITIONING_LIB -DQT_SENSORS_LIB -DQT_CORE_LIB -DQT_NEEDS_QMAIN -I..\demo320 -I. -I"D:\Program Files (x86)\ArcGIS SDKs\Qt100.0\sdk\include" -I"D:\Program Files (x86)\ArcGIS SDKs\Qt100.0\sdk\include\LocalServer" -ID:\Qt\5.8\mingw53_32\include -ID:\Qt\5.8\mingw53_32\include\QtOpenGL -ID:\Qt\5.8\mingw53_32\include\QtWidgets -ID:\Qt\5.8\mingw53_32\include\QtQuick -ID:\Qt\5.8\mingw53_32\include\QtGui -ID:\Qt\5.8\mingw53_32\include\QtANGLE -ID:\Qt\5.8\mingw53_32\include\QtXml -ID:\Qt\5.8\mingw53_32\include\QtQml -ID:\Qt\5.8\mingw53_32\include\QtNetwork -ID:\Qt\5.8\mingw53_32\include\QtPositioning -ID:\Qt\5.8\mingw53_32\include\QtSensors -ID:\Qt\5.8\mingw53_32\include\QtCore -Idebug -ID:\Qt\5.8\mingw53_32\mkspecs\win32-g++ -o debug\main.o ..\demo320\main.cpp

g++: error: /FS: No such file or directory

Makefile.Debug:517: recipe for target 'debug/main.o' failed

mingw32-make[1]: *** [debug/main.o] Error 1

mingw32-make[1]: Leaving directory 'E:/programing/c++/qt/build-demo320-Desktop_Qt_5_8_0_MinGW_32bit-Debug'

Makefile:34: recipe for target 'debug' failed

mingw32-make: *** [debug] Error 2

22:32:28: 进程"D:\Qt\Tools\mingw530_32\bin\mingw32-make.exe"退出,退出代码 2 。

Error while building/deploying project demo320 (kit: Desktop Qt 5.8.0 MinGW 32bit)

When executing step "Make"

22:32:28: Elapsed time: 00:01.

Has anyone else had issues like this?

Tags (1)
0 Kudos
1 Reply
LucasDanzinger
Esri Frequent Contributor

I see 2 issues in your screenshot from the post installer. The first is that for x86, you have the minGW kit selected, but we require the MSVC 2015 kit instead. The second is that for x64, you have the winRT kit selected, but we require the regular MSVC 2015 kit (not Windows RT).

Here is a link to the 64 bit kit - qt-opensource-windows-x86-msvc2015_64-5.8.0.exe

and the 32 bit kit - qt-opensource-windows-x86-msvc2015-5.8.0.exe

And here is the install guide for windows - Install and set up on Windows—ArcGIS Runtime SDK for Qt | ArcGIS for Developers 

- Lucas

0 Kudos