Does v100.0 support using a proxy?

263
2
Jump to solution
11-22-2016 07:18 AM
JonathonGrivas
New Contributor III

I'm searching the site using the full site search and I cannot find a reference to a proxy in the api reference for 100. It also won't return results for "proxy" for the QML 10.2.6 despite its setupProxy method, so I'm not sure how much I trust that site search tool now.  I downloaded the entire API reference so I could search it locally (sorry) and I still don't see results for "proxy". Is there a renamed method or any alternate way of routing all requests through Charles for testing?

(Sorry for so many questions in one day, I'm sure you're busy but I appreciate any help.)

0 Kudos
1 Solution

Accepted Solutions
LucasDanzinger
Esri Frequent Contributor

We no longer need a special method in our API - you just use a proxy the same way you would in any Qt application now (QNetworkProxy::setApplicationProxy). This is discussed here - Qt SDK best practices—ArcGIS Runtime SDK for Qt | ArcGIS for Developers 

Hopefully the search will improve as time goes on and the web crawler starts picking more things up.

View solution in original post

2 Replies
LucasDanzinger
Esri Frequent Contributor

We no longer need a special method in our API - you just use a proxy the same way you would in any Qt application now (QNetworkProxy::setApplicationProxy). This is discussed here - Qt SDK best practices—ArcGIS Runtime SDK for Qt | ArcGIS for Developers 

Hopefully the search will improve as time goes on and the web crawler starts picking more things up.

View solution in original post

JonathonGrivas
New Contributor III

Ah, great work! Thanks again for your help. I made the foolish assumption that it would still require separate ArcGISRuntime methods.