Currently we are working in ArcGIS Runtime SDK for qt verison 100.1 on OpenSuse with developer licence . We are exploring sample applicaions based on local server for displaying shapefiles. But the application is not displaying the shapefiles.The applic

402
7
Jump to solution
10-09-2017 10:57 PM
VishnuB
New Contributor III

0 Kudos
1 Solution

Accepted Solutions
LucasDanzinger
Esri Frequent Contributor

We have a sample in our v.next branch of our sample repo - arcgis-runtime-samples-qt/ArcGISRuntimeSDKQt_CppSamples/LocalServer/DynamicWorkspaceShapefile at v.n... 

It is technically for 100.2, but it will work with 100.1 as well. If you clone the repo and checkout the v.next branch, the only thing you will need to change to get it to work with 100.1 is to go into the .pro file and change ARCGIS_RUNTIME_VERSION from 100.2 to 100.1.

View solution in original post

0 Kudos
7 Replies
LucasDanzinger
Esri Frequent Contributor

We have a sample in our v.next branch of our sample repo - arcgis-runtime-samples-qt/ArcGISRuntimeSDKQt_CppSamples/LocalServer/DynamicWorkspaceShapefile at v.n... 

It is technically for 100.2, but it will work with 100.1 as well. If you clone the repo and checkout the v.next branch, the only thing you will need to change to get it to work with 100.1 is to go into the .pro file and change ARCGIS_RUNTIME_VERSION from 100.2 to 100.1.

View solution in original post

0 Kudos
VishnuB
New Contributor III

On running the  sample v.next Dynamic Workspace ( Linux )  , i am able to select the shapefiles , but its is still not rendering. .The  the localServer   logs shows  "datadir doesnot exist"  and  creates one , Please find the logs .

Also on an equal note is there anyway we could render locally stored  shapefiles without  instantiating LocalServer ?

Starting server

Licensed For Developer Use Only

Local server process started

'apppid' = '8545'

'cleanuponshutdown' = ''

'enablehtmlviews' = ''

'minport' = '5000'

'onlinux' = ''

datadir does not exist, creating: "C:\users\vishnu\Temp\arcgisruntime_45"

DataDir : "C:\users\vishnu\Temp\arcgisruntime_45"

Message : Logging disabled

DataDir : "C:\users\vishnu\Temp\arcgisruntime_45"

AppDataLocalDir : "C:\users\vishnu\LO~NQLRE\AP~4KI2A\ArcGISRuntime"

AppDataRoamingDir : "C:\users\vishnu\LO~NQLRE\AP~4KI2A\ArcGISRuntime/Roaming"

AppDataCommonDir : "C:\users\vishnu\LO~NQLRE\AP~4KI2A\ArcGISRuntime/Common"

MyDocumentsDir : "C:\users\vishnu\LO~NQLRE\AP~4KI2A\ArcGISRuntime/Documents"

CrashDumpPath : "C:\users\vishnu\Temp\ArcGISRuntimeErrorReports"

Message : Server version : 100.1.0.1744

Message : Server listening on : http://127.0.0.1:5000/k8W6N7/arcgis/rest

0 Kudos
LucasDanzinger
Esri Frequent Contributor

Did you make sure to setup the mpk_blank.mpk as described here - arcgis-runtime-samples-qt/ArcGISRuntimeSDKQt_CppSamples/LocalServer/DynamicWorkspaceShapefile at v.n... 

Basically, download that mpk and place it at C:\users\vishnu\ArcGIS\Runtime\Data\mpk\mpk_blank.mpk

As for rendering without local server, this will be possible in the next release of ArcGIS Runtime, which is due out near the end of this year.

0 Kudos
VishnuB
New Contributor III

Does ArcGIS Runtime SDK  have the capability to load a local offline base map , we could see that the base map is loaded from online resource . We want this process to offline.

We  are trying to develop a standalone application on embedded linux platform which is having some sophisticated map processing tasks . The data and the processing should be offline . In case this SDK does not support the above said feature, Can you suggest any other ArcGIS SDK which supports QT/C++ .

0 Kudos
LucasDanzinger
Esri Frequent Contributor

Yes, you can use ArcGIS Runtime SDK for Qt to load an offline basemap. You could load a tile package (TPK), raster data (tif, dted, img, etc), or use WebTiledLayer to read tiles from the local file system. What type of data are you wanting to load?

VishnuB
New Contributor III

Thank You very much, it worked. I tried to load a shapefile as basemap using local server.

VishnuB
New Contributor III

Thank you very much for you valuable support, currently i am facing a performance issue in the same. I used local map service to load a base map offline, it worked and the application is working fine without any performance issue, but after adding a graphics overlay to the map and while we zoom in or zoom out or pan the map, the previously loaded shapefile basemap is not loading properly. is there any option to refresh the map or any other option to fix this issue?

0 Kudos