undefined reference to `operator delete(void*, unsigned long)@Qt_5'

01-24-2020 12:26 AM
Occasional Contributor III


I tried to update from 100.6 to 100.7

While linking the executables i got an undefined reference:

lib64/libEsriCommonQt.so: undefined reference to `operator delete(void*, unsigned long)@Qt_5'

I´m using

  • openSUSE Leap 15.1
  • 5.13.1
  • gcc (SUSE Linux) 7.4.1

I tried to compile with a) -std=gnu++11 and b) -std=gnu++14, but no difference.

Which Qt did you use on Suse? The one of the operating system (suse) or did you compile Qt on your own?

Can you provide more information?

Thanks in advance!!!


0 Kudos
23 Replies
Occasional Contributor

Hi @EkkaratPrasongsap,

I am attaching the workaround library in this post. Also in my ArcGIS project at the very top of the library includes, I have included this library as follows:

LIBS += -L/home/fatma/Downloads/arcgisqthack/2020-11-09_ArcGISQt5Hack/ArcGISQt5Hack \
-lArcGISQt5Hack \

New Contributor II

Hi @FatmaAkdemir 

    Oh Great, Thank you very much. I can build a lib from this CMakeList and work on my machine.

Thank you very much.


0 Kudos
Occasional Contributor

Hi @NorbertThoden , I have used the cmake version did not create a pro file. I might have made some changes in cmake file.

Occasional Contributor III

Hi Fatma!

Can you share your CMakeLists.txt creating your ArcGisHack-Lib with us?
Thx in advance!