libEsriCommonQt.so: undefined reference to `operator delete(void*, unsigned long)@Qt_5' error

371
1
11-03-2020 11:06 PM
FatmaAkdemir
Occasional Contributor

I am upgrading my applications from arcgis qt 100.0.6 to 100.0.7 and after that I got this error :

/home/fatma/arcgis7/runtime_sdk/qt100.7/arcgis/runtime_sdk/qt100.7/sdk/linux/x64/lib/libEsriCommonQt.so: undefined reference to `operator delete(void*, unsigned long)@Qt_5'

How can I solve this? I have the correct version of Qt which I installed by using Synaptic in Ubuntu 20.0.4.

0 Kudos
1 Reply
NeilMacDonald
Esri Contributor

Hi Fatma, I see you have also been active in this thread:

https://community.esri.com/thread/247017-undefined-reference-to-operator-deletevoid-unsigned-longqt5 

It sounds like there's a difference between the Qt company supplied binaries and the package manager supplied binaries. Are you able to download the Qt libs from the Qt.io site (instead of using the package manager) and confirm if these work or not?

0 Kudos