Generating Large GeoDatabase

514
4
02-09-2017 07:30 AM
JonathonGrivas
New Contributor III

I'm trying to generate a somewhat large geodatabase, it has 7 layers but a few of them have image attachments and the whole thing comes out to several gigabytes. When I run this using the code in the qml sample for v100, it takes about 20 minutes and then says "File not found Error with download, geodatabase file is not present at the expected path.".   If I  remove some of the layers from the replica request, this does not happen.  Does anyone know what might be going wrong or how I can further test this? 

Additionally, running the same task on Android results in the app just spontaneously closing with no message of any kind in Qt Creator or on the device. I'm assuming this is an out of memory exception as the task eventually uses 6GB of ram on my desktop.  Is there any way to get the task to run safely on mobile, or are we going to have to pre-generate geodatabases and download/register them to get around this? 

Thanks,

Jon

0 Kudos
4 Replies
LucasDanzinger
Esri Frequent Contributor

Is the replica request actually failing and the gdb is indeed not there? I would check fiddler and also check the server logs to see if there is any hints. I would also try to run the exact same request, but do it in the browser on the service's Create Replica REST page. If it works there, then it is an issue in ArcGIS Runtime. If it fails there too, then it is an issue with the Server. That should help at least give us some hints as to where the issue lies.

0 Kudos
JonathonGrivas
New Contributor III

The replica request goes through its normal chain of progress updates and then a completed response. I can visit that URL to download the replica manually, so I think it's all working. However that file has a name like  _ags_data{9229625E937048DE9C27582E32519345}.geodatabase which is not the final name, so I'm uncertain if ArcGIS Runtime has to do something else with the file before it comes usable. 

0 Kudos
LucasDanzinger
Esri Frequent Contributor

This name looks like the temporary name it downloads it to before it completes. Does the signal emit saying it is complete? Can you listen to the errorChanged signal to see if you get any information about what is happening? Object QML Type | ArcGIS for Developers 

If that doesn't turn up anything, then your best bet would be to contact Esri Technical Support, as they could try and set up a similar environment to what you have to reproduce the issue. I agree that it is likely an issue with the Runtime API if you can manually download it successfully.

0 Kudos
JonathonGrivas
New Contributor III

I've verified the manually downloaded geodatabase works in the app, so it appears the problem is something client side. 

0 Kudos