Cmake "ArcGIS Runtime 100.8 Qt Quick app" template runtime problem

05-13-2020 11:18 PM
New Contributor

On windows: when selecting "ArcGIS Runtime 100.8 Qt Quick app" from the Qt creator wizard and selecting Cmake as buildssystem, where I set the following Cmake values:

  • ArcGISRuntime_EsriCommonQt_IMPLIB = C:\ArcGIS\Qt100.8\sdk\windows\x64\lib\EsriCommonQtd.lib
  • ArcGISRuntime_EsriCommonQt_LIB = C:\ArcGIS\Qt100.8\sdk\windows\x64\bin\EsriCommonQtd.dll
  • ArcGISRuntime_runtimecore_LIB = C:\ArcGIS\Qt100.8\sdk\windows\x64\bin\runtimecore.dll
  • ArcGISRuntime_INSTALL_DIR = C:/ArcGIS/Qt100.8
  • QML_IMPORT_PATH = C:/ArcGIS/Qt100.8/sdk/windows/x64/qml

I keep getting the following error during runtime debugging:

QQmlApplicationEngine failed to load component
qrc:/qml/main.qml:16 plugin cannot be loaded for module "Esri.ArcGISRuntime": Cannot load library C:\ArcGIS\Qt100.8\sdk\windows\x64\qml\Esri\ArcGISRuntime\ArcGISRuntimePlugind.dll: The specified procedure could not be found.

How can I fix this? Would it be possible to fix this in the "ArcGIS Runtime 100.8 Qt Quick app" template?

0 Kudos
4 Replies
Esri Contributor

Hi there, could you give me

* The version of CMake you are running.

* The version of Qt Creator you are running.

* The Qt version you are building against.

From the phrasing you've used, it sounds as if you setting the `ArcGISRuntime_INSTALL_DIR` and its derived properties manually. Is this the case? Normally these values should be picked up automatically from an INI file in your home folder.

Does the qmake projects template work as you expect?

Do you have openssl (libssl/libcrypto) libraries available on your development machine and are these discoverable by the executable?

0 Kudos
New Contributor


Thanks for your fast reply.

I'm using:

Cmake v3.16.4

qt creator 4.12.0

qt version 5.13.0

The `ArcGISRuntime_INSTALL_DIR` was indeed automatically found, however I needed to define these manually:

  • ArcGISRuntime_EsriCommonQt_IMPLIB
  • ArcGISRuntime_EsriCommonQt_LIB
  • ArcGISRuntime_runtimecore_LIB

Yes, the qmake build system version of the "ArcGIS Runtime 100.8 Qt Quick app" template works perfectly.

0 Kudos
Esri Contributor

I've copied over your settings as given above, but I've not been able to reproduce the problem.

If you need to define your own IMPLIB/LIB paths, this suggets to me that your CMake process is erroring out fairly early on into the process. Possibly the searches are failing?

Would you be able to provide

* The output of the `General Messages` log in Qt Creator when you run CMake for the first time on a new project.

* The contents of <build_folder>/CMakeFiles/CMakeOutput.log

* The contents of <build_folder>/CMakeFiles/CMakeError.log

0 Kudos
New Contributor

Interesting, would it be possible to upload your test project so I can see if it work here? Yesterday I tried it on a different pc, unfortunately the same problem. I used the same installation as prior, no luck. Then I uninstalled the sdk en reinstalled it with its default path (c:/program files (x86)/ ... ) however this resulted in the same error.

Which Compiler + version did you use on your tests?

Thanks in advanced!

0 Kudos