Invalid Response : This service does not support map capability

281
3
Jump to solution
03-03-2021 08:15 PM
YashvitNaik
New Contributor III

Hi,

I am using the Xamarin Android Runtime Package 100.7, While trying to load a feature service using the following code below, I get the exception saying "Invalid Response : This service does not support map capability"

ArcGISMapImageLayer imageLayer = new ArcGISMapImageLayer(serviceUri);
imageLayer.LoadAsync(); 
 
Have use the same bit of code to load service urls, for quite a while now. But right now only "mapserver" urls are loaded, the feature service wouldn't work (these are public).  
However if I downgrade to the older Esri version say 100.5, Both mapserver and featureserver urls load just fine.
 
Has anything changed in the way we load a feature server ?? Because I can confirm this is also happening on the iOS Xamarin Runtime package as well.
0 Kudos
1 Solution

Accepted Solutions
Dominique_Broux
New Contributor II

From the version 100.6, a MapImageLayer can be loaded only if the service supports the map capability i.e. if we are able to export the map as an image.

You can see the difference between a service that supports the map capability: http://sampleserver6.arcgisonline.com/arcgis/rest/services/Military/MapServer and a service that doesn't support it: http://sampleserver6.arcgisonline.com/arcgis/rest/services/Military/FeatureServer 

Only the former service supports the 'Export Map' operation (look at the bottom of the page).

With runtime versions previous to 100.6, it was possible to load the MapImageLayer because the map capability was not tested but we were actually unable to display any image.
Was your MapImageLayer working correctly with 100.5?

View solution in original post

3 Replies
Dominique_Broux
New Contributor II

From the version 100.6, a MapImageLayer can be loaded only if the service supports the map capability i.e. if we are able to export the map as an image.

You can see the difference between a service that supports the map capability: http://sampleserver6.arcgisonline.com/arcgis/rest/services/Military/MapServer and a service that doesn't support it: http://sampleserver6.arcgisonline.com/arcgis/rest/services/Military/FeatureServer 

Only the former service supports the 'Export Map' operation (look at the bottom of the page).

With runtime versions previous to 100.6, it was possible to load the MapImageLayer because the map capability was not tested but we were actually unable to display any image.
Was your MapImageLayer working correctly with 100.5?

View solution in original post

YashvitNaik
New Contributor III

Was your MapImageLayer working correctly with 100.5?

Yes it works, without any issues, for both feature server and map server, have tried with the same sample links mentioned above.

 

 
0 Kudos
MichaelBranscomb
Esri Frequent Contributor

Also note, feature services can only be used in conjunction with the ServiceFeatureTable Class and FeatureLayer Class while map services are typically only used in conjunction with the ArcGISMapImageLayer Class.