Inherit from LocationDataSource and gray symbol

341
2
Jump to solution
07-20-2017 06:09 PM
Highlighted
New Contributor III

Using the ArcGIS Runtime 100.1 we are creating an application that is already reading the GPS device and the map is to display the current location of the device.  The Esri.ArcGISRuntime.Location.LocationDataSource has been inherited from to create a new class that is used to set the location based on the GPS device.  The new class calls on the base.UpdateLocation with the information from the GPS device.

The current location is being correctly displayed on the map.  The issue is that the symbol that is displayed is gray rather than the default blue.  We would like to use the default symbols and not have to configure a different symbol.  The question is, why is the symbol gray and not blue.  When the default LocationDataStore is used with the MapView.DisplayLocation, the blue symbol is used.

Thanks,

Scott

Reply
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Esri Frequent Contributor

Are you setting the last parameter 'IsLastKnown' in the location object to true or false? (You want to set it to false, or it's going to consider the location "outdated" and will turn gray).

View solution in original post

2 Replies
Highlighted
Esri Frequent Contributor

Are you setting the last parameter 'IsLastKnown' in the location object to true or false? (You want to set it to false, or it's going to consider the location "outdated" and will turn gray).

View solution in original post

Highlighted
New Contributor III

Thanks Morten!  Setting the Location.IsLastKnown = false worked; the active blue symbol is used.

Reply
0 Kudos