How do I fix the fuzzy rendering?

2373
1
04-17-2015 12:24 PM
Highlighted
New Contributor

In the ArcGIS Runtime for WPF, the map was rendered fuzzy unless you set UseLayoutRounding to 'True' for the esri:Map control. In the new .NET API, I cannot set this value for the Map control. I can only set it on the MapView and it doesn't do the trick. See the samples below: Image on left is .NET, image on right is WPF. Does anyone know what the new approach to fixing "fuzziness" is? I am using local dynamic layers (referencing sde data), not tiled.

Thanks for any help you could offer.

Reply
0 Kudos
1 Reply
Highlighted
New Contributor II

Doug,

I'm not sure this is the "proper" answer, however I was having a similar issue and this helped quite a bit.  My team lead sent me a sample, and I noticed his basemap renders very crisp/clear, while mine was rendering fuzzy.  I messed with it for quite some time (we're both using the .NET Runtime SDK, not the WPF SDK), and this is what I came up with.  The Grid element I'm speaking of is my topmost container element on the window (<Window...><Grid...><MapView.../></Grid></Window>).

Originally my Grid (5 x 5) had controls along the top, left and right edges with the map in the middle of the window:

<esri:MapView ... Grid.Row="1" Grid.Column="1" Grid.ColumnSpan="3" Grid.RowSpan="4">

As soon as I set the MapView to start drawing from the top left of the window, and just let my controls draw on top of the map, it started rendering much more clearly.  While this is a lot better than it was, it still isn't rendering nearly as crisp as your WPF example.  So if you happened to find something more solid please share it with us here, but this definitely made mine more clear.

<esri:MapView ... Grid.Row="0" Grid.Column="0" Grid.ColumnSpan="5" Grid.RowSpan="5">

Reply
0 Kudos