Geoprocessing service failed to start ??

536
24
Jump to solution
10-06-2018 10:06 PM
Highlighted
New Contributor II

Hi,

I am using ArcGIS Runtime SDK for .Net to develop a WPF App which is trying to demonstrate how to perform geoprocessing tasks using Local Server by duplicating the code from ArcGISRuntime.WPF.Viewer and making necessary changes in the code.

After debugging I get a exception message "geoprocessing service failed to start."

I have installed all the necessary references and SDKs and nuget packages as well.

I am attaching the XAML and C# code files as well.

Please let me know what am I not doing right to get the app started.

Thank you,

Manish

Reply
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Esri Frequent Contributor

Hi,

Can you try the following?

- Open the deployment file (`ArcGISLocalServer_100.3.AGSDeployment`)

- Set the Pro package to false (`<Package id="Pro" name="ArcGIS Pro Compatible Server" enabled="false">`)

- And/or set the ArcMap package to false (`<Package id="ArcMap" name="ArcMap Compatible Server" enabled="false">`)

Setting the deployment to false will ensure the LocalServices API uses the Local Server SDK installation location where all Local Server files are located.

For more information see Create a Local Server deployment—ArcGIS Runtime SDK for .NET (WPF) | ArcGIS for Developers 

Cheers

Mike

View solution in original post

24 Replies
Highlighted
Esri Contributor

I unzipped your attached folder but found no project contained within it.

What version of the ArcGIS Runtime SDK and Local Server are you using? Have you enabled Geoprocessing in the .AGSDeployment file that gets created after compiling your project?

I have a sample that uses Local Server 100.2.1 and it appears to work. However this same sample is failing when using Local Server 100.3. I will look into this issue further. 

Highlighted
New Contributor II

Kimberly, I am using ArcGIS Runtime SDK and Local Server 100.3. I didn't include the project solution in zip because after installing nuget packages for local server the size of the application gets huge. If there is a way I can send you the entire project file, let me know. Otherwise let me know the minimum files you need to see through it.

I have enabled the Geoprocessing in the .AGSDeployment.

I really need help on this.

Reply
0 Kudos
Highlighted
Esri Contributor

I didn't see any files in the zip folder at all. It's okay though, I've got a sample set up and am troubleshooting why we cannot start the geoprocessing service using ArcGIS Runtime 100.3.

What exactly is your error message?

Reply
0 Kudos
Highlighted
Esri Frequent Contributor

Hi,

Can you try the following?

- Open the deployment file (`ArcGISLocalServer_100.3.AGSDeployment`)

- Set the Pro package to false (`<Package id="Pro" name="ArcGIS Pro Compatible Server" enabled="false">`)

- And/or set the ArcMap package to false (`<Package id="ArcMap" name="ArcMap Compatible Server" enabled="false">`)

Setting the deployment to false will ensure the LocalServices API uses the Local Server SDK installation location where all Local Server files are located.

For more information see Create a Local Server deployment—ArcGIS Runtime SDK for .NET (WPF) | ArcGIS for Developers 

Cheers

Mike

View solution in original post

Highlighted
New Contributor II

Mike, both these settings have been applied. still gives me same message

Reply
0 Kudos
Highlighted
Esri Frequent Contributor

Hi,

If that's the case, then it's likely to be an issue within your script/model causing the error.

What version of ArcMap or ArcGIS Pro are you using?

Can you share the Toolbox containing the script/model?

Cheers

Mike

Highlighted
New Contributor II

Mike I am just trying to reuse https://github.com/Esri/arcgis-runtime-samples-dotnet/tree/master/src/WPF/ArcGISRuntime.WPF.Viewer/S... and make it an independent WPF tool rather than a user control. I am using same codes and same data (I am accessing the same data from a different location) as in picture below

Reply
0 Kudos
Highlighted
Esri Frequent Contributor

Hi,

You may need to set the TempPath property to a shorter path (by default it uses your user profile temp).

ArcGISRuntimeEnvironment.TempPath Property 

e.g. to verify if this is the case here try something like "C:\Temp".

Cheers

Mike

Highlighted
New Contributor II

Still no luck.

Reply
0 Kudos