10.2.4 Label Visibility Bugs?

3797
2
10-15-2014 07:28 PM
New Contributor II

I've been playing with displaying FeatureLayers from a local .geodatabase file.

I've organised some of these layers within a GroupLayer. For example:

  • Roads (GroupLayer)
    • Motorway (FeatureLayer from local geodatabase)
    • Trunk (FeatureLayer from local geodatabase)
    • Primary (FeatureLayer from local geodatabase)
    • Secondary (FeatureLayer from local geodatabase)
    • ...

Each of these FeatureLayers is labelled with the street name.

Observation 1) The label do not respect the visibility of the parent group layer: If I set the visibility of the parent grouplayer (Roads) to false, the features get hidden but the labels will still be displayed. Is this a bug?

Observation 2) The order in which I set visibility of a feature layer and enable/disable the labels is important.

For example, if I set the visibility of the primary road layer to true and enable the labelling, depending on the order in which I perform this, labels may not appear until the map is panned. Is this a bug?

Reply
0 Kudos
2 Replies
Esri Frequent Contributor

Hi,

1) Labels do not respect the visibility of the parent group layer:

I can confirm this is a known issue in the 10.2.4 release which we would like to address in the next release. In the mean time you will need to iterate the child layers and enable/disable label visibility.

2) The order in which visibility of a feature layer and enable/disable the labels is set is important:

This sounds like it could be an issue - please can you attach your reproducer app?

Cheers

Mike

Regular Contributor

I see the group layer label issue is fixed at 10.2.5, and I successfully removed my workaround code.  Thanks,