System.NotSupportedException while working with MapView

879
5
02-26-2018 10:15 PM
SougataBasu
New Contributor

Error : System.NotSupportedException: Could not activate JNI Handle 0x7fca1a7480 (key_handle 0x2ad6405) of Java type 'Esri/ArcGISRuntime/UI/MapView' as managed type 'Esri.ArcGISRuntime.UI.MapView'.

I am facing this error while working with ESRI map in a existing project.

Below is the package information -

package id="Esri.ArcGISRuntime.Xamarin.Android" version="100.2.0" targetFramework="monoandroid60"

This error exists in version="100.2.1" also.

I have followed all replies of this thread :  System.NotSupportedException: Could not activate JNI Handle 0x7fca1a7480 (key_handle 0x2ad6405) of ... 

But that didn't work for me.

Please reply with some solution ASAP.

Tags (1)
0 Kudos
5 Replies
MichaelBranscomb
Esri Frequent Contributor

Hi,

 

Please can you provide more information about your current Android project settings? (Android target framework, supported architectures enabled, etc).

 

Cheers

 

Mike

0 Kudos
SougataBasu
New Contributor

Hi,

Below are the details-

Android target framework : Android 6.0 (Marshmallow)

Supported Architectures : armeabi; armeabi-v7a; x86

Package Information : 

package id="Esri.ArcGISRuntime.Hydrography" version="100.2.0" targetFramework="monoandroid80"

package id="Esri.ArcGISRuntime.Xamarin.Android" version="100.2.0" targetFramework="monoandroid80"

0 Kudos
SougataBasu
New Contributor

Hi Mike,

Please let me know if any other detail I need to provide and reply with some solution ASAP as I am stuck.

0 Kudos
MichaelBranscomb
Esri Frequent Contributor

Hi,

It sounds like you might be running into Could not activate JNI Handle — Xamarin Forums ?

Cheers

Mike

0 Kudos
dotMorten_esri
Esri Frequent Contributor

If any of you are experiencing this issue on a device running Android v4.2 or older (API level 17 or below), try adding the following line of code to the Application's constructor:

 Java.Lang.JavaSystem.LoadLibrary("runtimecore");

0 Kudos