synchronyzing offline edits, ok for delete & addnew , NOT OK for update

1731
4
Jump to solution
07-16-2016 04:53 AM
prigoreanuconstantin
New Contributor II

Hi,

This works ok, offline updates (to geometry) are saved in the offline geodatabase:

Geometry geometry = await MyMapView.Editor.EditGeometryAsync(feature.Geometry);

feature.Geometry = GeometryEngine.Simplify(geometry);

await table.UpdateAsync(feature);

But, after about 10 days of haotic work, i don't see the light: any offline update, dissapears AFTER SYNCHRONIZATION and DOESN'T SHOW UP in the PostgreSQL-Geodatabase (SDE) Feature Class;

Could you , please, give me some broad-steps indications, on how to synchronize offline updates?

Even detailed indications wouldn't hurt .

Your samples do not cover offline updates synchronizing, (just addnew), and its almost impossible for me to put togeather the online documentation, and to sort it out .

I'm afraid i'll have to keep on trying for 2-3 months...with no outcome guaranteed.

Thanks.

0 Kudos
1 Solution

Accepted Solutions
prigoreanuconstantin
New Contributor II

now the new one is also synchronizing perfectly, but i'v done so many re-generating of the feature class, in so many ways, that i forgot what i'v done right or wrong;

  any how, after failing only 2000 times, now i'v managed to have 2 services synchronizing perfectly: my conclusion: it can be done, i can synchronize offline updates to features back to the server.

View solution in original post

0 Kudos
4 Replies
prigoreanuconstantin
New Contributor II

i haven't modified the source code , i have just upgraded virtualbox , and today, for the VERY FIRST TIME, updates to any feature geometry, are synchronizing perfectly.

i will try again from the beginning, to see if it still holds water , so to speak!

0 Kudos
prigoreanuconstantin
New Contributor II

i have started from scratch, and so, now i have 2 setups, running in parallel, the old one its working, the new one, its not.

I'll try to find out why, but i have a feeling the running one, its just temporary doing ok.

0 Kudos
prigoreanuconstantin
New Contributor II

Failed to synchronize replica: postgres.DOTNET_Sample_1469003761775. Failed to start multi-user editing on target workspace. The field is not nullable.

0 Kudos
prigoreanuconstantin
New Contributor II

now the new one is also synchronizing perfectly, but i'v done so many re-generating of the feature class, in so many ways, that i forgot what i'v done right or wrong;

  any how, after failing only 2000 times, now i'v managed to have 2 services synchronizing perfectly: my conclusion: it can be done, i can synchronize offline updates to features back to the server.

0 Kudos