Runtime Labels Don't Behave According to Settings in ArcMap

12-14-2015 11:20 AM
New Contributor III

I am having an issue with our runtime app that has only recently began occurring. We are currently running Runtime Engine 10.2.5 for our app, and I have recently upgraded to ArcMap 10.3.1 (although going back to v10.3 after these issues occurred didn't solve my dilemma, so I don't think an upgrade would cause this issue).

Labels don't seem to be following the settings I apply to them in ArcMap, and it's becoming an issue with some of our customers.

Here is a picture of a group of streets in the ArcMap application:

These are my label settings I use:

This is what the same location looks like in my app (you will notice more data in the app; I use multiple MXDs - one for basemap data, another for streets, another for structures, and another for zones):

This is too much text for what we need, and it only worsens if I put the labels above or below the line instead of on it. If I changed the buffer to 15, my app will still show this exact same image you see above. This was not happening a few months ago, and no major updates to our app have been done in 6 - 8 months.

What could be happening? I do overwrite existing .geodatabase files, but I will manually delete the current .geodatabase and ensure the new .geodatabase is saved to the same location and similar results occur. I've tried repairing ArcMap, thinking that the way it was generating the runtime content was somehow having an issue. I've uninstalled extensions, reinstalled extensions, uninstalled all ArcGIS products entirely and reinstalled them. I've tried everything I can think of, and I'm out of ideas.

Can anybody point me in the right direction?


0 Kudos
0 Replies