MapView ShowCalloutAt not working properly

457
3
04-29-2020 10:35 PM
YaronAvraham
New Contributor III

I'm trying to show tooltip on map using the ShowCalloutAt method,

and i ran into problems with it, when i try to style the tooltip a bit i get the following result

see the white arrow beside the main tooltip.

my code:

 var callout = new Callout()
                                {
                                    Background = new SolidColorBrush(Color.FromArgb(255, (byte)51, (byte)51, (byte)51)),
                                    BorderBrush = new SolidColorBrush(Color.FromArgb(255, (byte)102, (byte)102, 102)),
                                    Foreground =  Brushes.White,
                                    BorderThickness = new Thickness(1),
                                    Padding = new Thickness(8,3,8,4),
                                    HorizontalContentAlignment = HorizontalAlignment.Left,
                                    VerticalContentAlignment = VerticalAlignment.Center,
                                    Content = calloutAction.Text
                                };
                                ArcMapView.ShowCalloutAt(calloutAction.location, callout);‍‍‍‍‍‍‍‍‍‍‍‍

the second issue is when i dont use my own style, and use CalloutDefinition:

  ArcMapView.ShowCalloutAt(calloutAction.location, new CalloutDefinition(calloutAction.Text));

i get the following "bug" sometimes, the popup wont show at all and the text is written to the right of the graphics

i'm using 100.6 SDK and the popup is shown on MoveMouse event

0 Kudos
3 Replies
MichaelBranscomb
Esri Frequent Contributor

Hi,

We made several improvements to the Callout for v100.8, which was released yesterday. Please can you retest and let us know if the issues you're seeing with Callout size and placement?

Thanks

Mike

0 Kudos
YaronAvraham
New Contributor III

Hi,

well, the problem was not fixed, it changed.

when i try the code with the custom styled Callout, it will show blank white callout without text and without style.

when i try the CalloutDefinition it will work at the beginning, and after few popups the UI thread enters a DeadLock and the entire program freezes.

seriously, are you testing the code in real life scenarios before you release the SDK ?

another issue is we use ArcgisRuntime.LocalServices and the latest version of it is 100.6 it wont work with runtime 100.8

any plans on releasing ArcgisRuntime.LocalServices 100.7/8 ?

Thanks!

0 Kudos
MichaelBranscomb
Esri Frequent Contributor

Hi,

Can you share the code you are using for handling mouse move?

It will be useful to know what other logic is running on mouse move e.g. identify, and what check(s) you have for returning from the mousemove early based on time/distance delta.

Thanks

Mike

0 Kudos