Ignore GeoViewTapped when zooming via Double tap (v100.2)

811
4
02-14-2018 01:20 PM
ChrisSmith12
New Contributor II

I'm using the GeoViewTapped event on MapView to show callouts for various objects. I would like to still support double click to zoom, however, when the user double taps my GeoViewTapped event fires causing callouts to be shown. Is there a way to disable or ignore GeoViewTapped events when the user double clicks on the map? Thank you.

0 Kudos
4 Replies
MaraStoica4
Occasional Contributor

Hi Chris,

There's a good example of what you're wanting to do in our Offline Mapbook example app. Hope this helps!

https://github.com/Esri/mapbook-wpf

Mara

ChrisSmith12
New Contributor II

Thanks for your help Mara.

0 Kudos
dotMorten_esri
Esri Frequent Contributor

You're getting into an issue with gesture overlap. Basically you're using the same gesture for two things, and that's not going to go too well as you've found .

The only workaround you can really do here is to not act on the tapped event for a little while. If no double tapped event occurs, you move forward, but the downside there is the action will seem a little slower than it really is.

Alternatively I'd suggest you consider other gestures like right-click, ctrl+click, enable a tool etc to avoid the gesture overlap.

ChrisSmith12
New Contributor II

Thanks Morten

0 Kudos