ArcGIS Enterprise: Unable to sync offline areas

343
2
01-27-2021 08:28 PM
ChadMinteer
Occasional Contributor

When we are trying to sync an Offline Area it's throwing an error- " Error while handling get server sync job status. Job error 500 [\"ErrorMsg@SyncGPService:{\\\"code\\\":500,\\\"description\\\":\\\"Failed to synchronize.\\\"}\",\"Failed to execute (Sync Feature ServiceReplica).\",\"Failed.\"]." 

Any lead what might be the underlying issue as other services are working fine this issue is only repeatable in one particular enterprise. The only difference here is we are using ArcGIS data store in this enterprise service. 

 

Tags (3)
0 Kudos
2 Replies
twakim
by
New Contributor

Chad,

Have you checked the server log to see if there is a more descriptive error message, or additional error info that could help identify the cause of sync failing?

Tony Wakim

0 Kudos
JoeHershman
MVP Regular Contributor

Ah wonderful Job error 500, the mystery issue that could be anything.  Like mentioned above checking server logs could give more information.  I would do a job.ToJson() to get the communication between the server and client.  This will let you know what specific layer is failing.  Search for warnings, because for some reason layers failing to sync is not logged as an error.

Once you know the layer you can take a look at the actual replica itself.  These can be opened in Pro.  We have seen sync errors occur if you have corrupted data in the replica.  This doesn't seem to cause problems in the Runtime app but cause a sync failure.  Geometry and DateTime fields tend to be the culprit from my experience.

Good luck

 

0 Kudos