ArcGIS Desktop and Runtime GPKs: Version Compatibility

767
3
10-21-2016 03:52 PM
MarkCederholm
Regular Contributor II

GPKs created using Desktop 10.2.1 and 10.3.1 work fine with Runtime 10.2.7, but GPKs created using 10.4.1 and 10.5.PR do not.  I've been told that certain versions of ArcMap/ArcCatalog are only compatible with certain versions of Runtime, because of an ArcObjects compatibility issue.  If so, will 10.4.1 and 10.5 support the Quartz release?  [The current Quartz Beta doesn't have a local server yet that I can test.]

Tags (3)
0 Kudos
3 Replies
MarkCederholm
Regular Contributor II

Well, I finally got around to doing some testing on 100.0, and GPKs from 10.3.1, 10.4.1, or 10.5.0 all bomb when started up.  I can start up an MPK fine, but it doesn't display rasters; however, I can display rasters separately, so that's not a big issue.  Also, TPKs and tile caches with custom tiling schemes won't display.  CORRECTION: Runtime doesn't like custom tiling schemes with only one scale level defined.  If I have two or more scale levels defined, then the TPK is displayed between the minimum and maximum scales.

0 Kudos
AnttiKajanus1
Regular Contributor II

Hi Mark,

There is mention about this in the System requirements documentation (weirdly this is not mentioned in local server package support document but I'll add in issue to fix that).

ArcGIS Desktop 10.4.1 is required to create content packaged for Local Server 100.0.0. This includes map packages and geoprocessing packages (.mpk and .gpk). If you are creating geoprocessing packages then you will also need to apply this patch to ArcGIS Desktop 10.4.1

I strongly recommend to install the patch mentioned.

At the moment we don't support direct read for rasters through Local server but as you mentioned, we should be able to use direct read through Raster layer for that.

How are you using TPKs and which kind of custom tiling scheme you are using?

0 Kudos
MarkCederholm
Regular Contributor II

Thanks for the info.  I applied the patch, recreated the GPK, and still get the error.  I've attached it as an example.  As for the TPKs, I've also attached two examples: one with the old tiling scheme that doesn't work, and one with the revised tiling scheme that does work.

0 Kudos