problem with ESRi Training: Mobile GIS: Getting Started with the ArcGIS API for iOS

1209
3
02-23-2012 04:57 PM
AdamAaron
New Contributor
Hi

I trying to teach myself how to make mobile apps for the iOS, So i bought two classes from ESRI in December.

Well that have not updated the class to match with the new 4.3 or the new OS Lion. The people at ESRI Training have been very unhelpful, I was hoping the forum could set me in the right direction. I did the class did like it said, but all i get is a white screen in the simulator (The web map did not load). I also tried using the soultion files but no luck. I have attached my project below. here is the software requirement for the class:

ArcGIS API for iOS 2.0
Macintosh computer running Snow Leopard
Xcode 4
iOS SDK 4.3 or higher
Included with the Xcode 4 installation

This is my software"

ArcGIS API for iOS 2.1
Macintosh computer running Lion 10.7.3
Xcode 4.3
iOS SDK 5

I feel like this is some syntax error that not registering. please help1
0 Kudos
3 Replies
Nicholas-Furness
Esri Regular Contributor
Hi

I trying to teach myself how to make mobile apps for the iOS, So i bought two classes from ESRI in December.

Well that have not updated the class to match with the new 4.3 or the new OS Lion. The people at ESRI Training have been very unhelpful, I was hoping the forum could set me in the right direction. I did the class did like it said, but all i get is a white screen in the simulator (The web map did not load). I also tried using the soultion files but no luck. I have attached my project below. here is the software requirement for the class:

ArcGIS API for iOS 2.0
Macintosh computer running Snow Leopard
Xcode 4
iOS SDK 4.3 or higher
Included with the Xcode 4 installation

This is my software"

ArcGIS API for iOS 2.1
Macintosh computer running Lion 10.7.3
Xcode 4.3
iOS SDK 5

I feel like this is some syntax error that not registering. please help1


Hi Aaron,

I'm sorry to hear you're having trouble.

I've built myself a VM with Mac OS X updated to 10.7.3 and Xcode 4.3 downloaded from the Apple App Store as well as the latest ArcGIS API (2.1). However, I'm unable to reproduce the problem. The solution you attached builds and runs fine and shows me the expected map display in the iPhone simulator. At least we know it's not a syntax error 🙂

Are you able to run the attached project and see a map of the world? Note: you may need to change the "Library Search Paths" project build setting.

If not, could there be network problems/firewalls preventing you from accessing the data sources? Try opening this link from your developer machine. You should see a map of San Francisco 311 incidents.

Cheers,

Nick.
0 Kudos
AdamAaron
New Contributor
Hi Nick,

Thank you so much!! you lead me down the right path. the TestOverlay1 file you sent worked just fine. So i used the file model my file after!

I noticed I had misplaced a path and my iOS deployment was set to 4.3 not 5.0.

Your response and file you sent was super helpful, again Thank You!

.....make me want to post to this forum more:)
0 Kudos
Nicholas-Furness
Esri Regular Contributor
.....make me want to post to this forum more:)


And so you should, Adam (sorry I called you Aaron before!)! Glad you were able to work it out.

Please do post here if you encounter problems with the SDK. We can't always promise to solve every problem, but we do the best we can 🙂

Nick.

(BTW, if there's a checkmark on the post I provided above, perhaps you could mark this answered? It helps as I scan forum posts to see if I can help out.)
0 Kudos