Map Label centers itself when panning map after update from ArcGIS iOS SDK 100.6 to 100.9

324
3
Jump to solution
02-10-2021 10:11 AM
MichaelHorii
New Contributor II

Hi, I noticed that after updating from ArcGIS iOS SDK 100.6 to 100.9, map labels behave differently. In 100.6, my app displayed labels at specific points on the map. As the user panned the map, those labels stayed in their fixed points and moved relative to the map -- in other words, as the map was panned left, the label moved left; as the map was panned right, the label moved right. In 100.9 however, the labels now move themselves so as to stay centered on the screen, even as the map is panned. 

Is there some new property that I can set to make the labels behave in the way that it behaved in 100.6? 

0 Kudos
1 Solution

Accepted Solutions
RichardJShepherd
New Contributor II

Thanks for the info, Michael. I've reproduced what could be a similar problem. As I pan, polygon labels that are moving offscreen are moving their center within their polygon to stay on screen.

This is intended behavior.

But, they shouldn't be doing that at the cost of removing other nearby labels that aren't needing to move.

I've logged a bug for that, and we'll look into it.

We also what to add additional controls, especially for polygon labels, which have very few. `FixedPosition` is one of them, which will give you the more stable display (at the cost of losing labels earlier as you pan).

You could set the Overrun property to None which would stop labels overrunning outside their own polygon (and having knockon effects on other labels), and then zoom in to see labels in smaller or awkwardly shaped polygons?

View solution in original post

0 Kudos
3 Replies
RichardJShepherd
New Contributor II

Hi, Michael. I can think of a few areas we changed in Runtime Labeling between 100.6 and 100.9. I'm guessing that your labels were on Line or Polygon features? Both have had bugs corrected in recent versions in order to give the most commonly required behavior. Could you describe the data and/or labeling properties that you were using?

We have an ongoing plan to provide more and more configurability and to support more of the ArcGISPro labeling preferences. Queries and problems like yours help us to prioritize what to tackle next.

0 Kudos
MichaelHorii
New Contributor II

Hi Richard, thanks for your reply. The labels are on Polygon features, I believe. In my code I set the LabelPlacement property to "esriServerPolygonPlacementAlwaysHorizontal", and the type property to "esriTS", as the labels are text symbols. 

 

0 Kudos
RichardJShepherd
New Contributor II

Thanks for the info, Michael. I've reproduced what could be a similar problem. As I pan, polygon labels that are moving offscreen are moving their center within their polygon to stay on screen.

This is intended behavior.

But, they shouldn't be doing that at the cost of removing other nearby labels that aren't needing to move.

I've logged a bug for that, and we'll look into it.

We also what to add additional controls, especially for polygon labels, which have very few. `FixedPosition` is one of them, which will give you the more stable display (at the cost of losing labels earlier as you pan).

You could set the Overrun property to None which would stop labels overrunning outside their own polygon (and having knockon effects on other labels), and then zoom in to see labels in smaller or awkwardly shaped polygons?

View solution in original post

0 Kudos