iOS Runtime SDK APP || iPa Payload Package Added ArcGIS.bundle 2 Times

673
3
02-17-2019 02:33 PM
ManasaParida
New Contributor III

Dear Team,

Could you please find the attached screenshot below when i was trying to expand the Payload package after the iPa  

Also from the iOS SDK veriosn 100.4 printing this debug log in Xcode Console.

2019-02-18 01:29:26.034694+0300 QNavigation[293:9557] Task <08CBEE46-3B94-4932-85F6-AF36DBDA03BA>.<189> load failed with error Error Domain=NSURLErrorDomain Code=-999 "cancelled" UserInfo={NSErrorFailingURLStringKey=https://services.gisqatar.org.qa/server/rest/services/Imagery/QatarSatelitte/MapServer/tile/3/263/210, NSErrorFailingURLKey=https://services.gisqatar.org.qa/server/rest/services/Imagery/QatarSatelitte/MapServer/tile/3/263/210, _NSURLErrorRelatedURLSessionTaskErrorKey=(

    "LocalDataTask <08CBEE46-3B94-4932-85F6-AF36DBDA03BA>.<189>"

), _NSURLErrorFailingURLSessionTaskErrorKey=LocalDataTask <08CBEE46-3B94-4932-85F6-AF36DBDA03BA>.<189>, NSLocalizedDescription=cancelled} [-999]

0 Kudos
3 Replies
Nicholas-Furness
Esri Regular Contributor

The first issue is that you've embedded the dynamic framework in your app. This is fine, but if you do that, you should not also include the ArcGIS.bundle in the project hierarchy as it's included in the dynamic framework (as you can see from your first screenshot). Currently, the Guide shows how to add the static framework to your app. We will soon update the documentation to cover the dynamic framework (we used to only provide the static framework), but in the meantime please take a look at this GeoNet post.

See later reply for more details.

The second issue is tile requests being cancelled as you pan and zoom around the map. If you are panning and zooming quickly and the Runtime makes a request for a tile that you pan and zoom away from before the tile data response is received, Runtime cancels the request. These messages are simply reflections of those cancelations.

0 Kudos
ManasaParida
New Contributor III

Dear Nicholas,

Thanks for the update.

Yes, i have embedded the dynamic framework through pod which is really good.

But, i have not added ArcGIS.bundle in the project hierarchy because i remember it was earlier when i was started ArcGIS but from last 4 to 5 Months i am using through pod only, also i have checked my project hierarchy there is no where i had setup ArcGIS.bundle manually rather than pod, please let me know meanwhile i am attaching few of my screen shot for more clarity.

0 Kudos
Nicholas-Furness
Esri Regular Contributor

Just to close this out, after offline discussion (thank you, Manasa) it turns out the dual inclusion was down to a bug in our Cocoaspec for 100.4. This is fixed at release 100.5. Note that the impact on app size is about 1.1Mb (the compressed size of the bundle, which is largely highly-compressible text-based localization files).

0 Kudos