iOS 6 + iPhone 5 - Map Tiles Fail to Load

1126
6
Jump to solution
09-26-2012 12:04 PM
AaronConnolly
Occasional Contributor
Hi,

I'm experiencing another problem with the map on iPhone 5. If you zoom out a great distance, quickly sometimes the map tiles will fail to load. I don't see any exceptions or error messages from the map, either.

Attached is a screen shot and I can send you a project that can be used (when run on iPhone 5 directly) to reproduce the issue if you would like.

Any ideas?

Thanks,
- Aaron
0 Kudos
1 Solution

Accepted Solutions
NimeshJarecha
Esri Regular Contributor
Is this working for you now?

Regards,
Nimesh

View solution in original post

0 Kudos
6 Replies
NimeshJarecha
Esri Regular Contributor
Please send the project, i would like to see that.

Regards,
Nimesh
0 Kudos
AaronConnolly
Occasional Contributor
Hi Nimesh, can I send you the project directly? I'm not able to post it here because it's 3.3 MB and the limit for a .zip is 2.0 MB. You can reach me at aaron at theomegagroup dot com, if you'd like.

Thanks,
- Aaron
0 Kudos
NimeshJarecha
Esri Regular Contributor
Hi Aaron,

I got your project from Al which you shared in Dropbox. You said "map tiles will fail to load". The URL you are using is cached map service but in code you are using AGSDynamicMapServiceLayer. Why? You should use AGSTiledMapServiceLayer.

Regards,
Nimesh
0 Kudos
AaronConnolly
Occasional Contributor
Hi Aaron,

I got your project from Al which you shared in Dropbox. You said "map tiles will fail to load". The URL you are using is cached map service but in code you are using AGSDynamicMapServiceLayer. Why? You should use AGSTiledMapServiceLayer.

Regards,
Nimesh


Ni Nimesh, thanks for taking a look at my projects. I didn't realize there was critical difference between the two layer objects. I'll be more careful in the future and I'll update both apps that I sent you to use the correct object. Looking at the docs now its clear that one is meant for static caches and the other is for caches whose properties can change on the fly.
0 Kudos
NimeshJarecha
Esri Regular Contributor
Is this working for you now?

Regards,
Nimesh

View solution in original post

0 Kudos
AaronConnolly
Occasional Contributor
Nope! This issue looks to be taken care of by switching from the dynamic map service layer to the tiled map service layer.
0 Kudos