How to transition from older SDK (v2.1) to the latest (10.2)?

2498
2
Jump to solution
10-31-2014 06:50 AM
JamesPower1
New Contributor II

I am working on an application that used a very old version of the SDK (in the notes I was given it says 2.1, though I'm not sure how best to verify that). In order to support arm64 I've stripped out the old SDK and included 10.2 via Cocoapods. My main question is: are there transition notes somewhere for updating between major SDK revisions?

The issue I'm currently running into is this:

The app relies on the "AGSMapViewDelegate" protocol which is documented here: ArcGIS API for iOS 1.0  as having existed since v1.0. I don't see any deprecation status on this page so I assume it should still be around. However neither AGSMapView.h or AGSMapViewBase_iOS.h contain the protocol definition.

I'm hoping there are a couple documents with transition notes between major SDK versions I can follow to help me muddle through this and other similar issues I'm sure to run into while updating this application.

0 Kudos
1 Solution

Accepted Solutions
AlPascual
Esri Contributor

2.1 is a very old SDK, we had many releases from 2.1 to 10.2 as you can see on the Product Life Cycle document:

http://downloads.esri.com/support/product%20life%20cycle/developers/ArcGISiOSSDK_PLC.pdf

SDK 10.2 October 29, 2013 October 2013 – March 2014

SDK 10.1.1 April 2013 X Retired

SDK 2.3.2 July 2012 X Retired

SDK 2.3 June 2012 X Retired

SDK 2.2.X Nov 2011 X Retired

SDK 2.1 July 2011 X Retired

The versions between are now retired, you can get release notes for 10.1.1 only Release notes for 10.1.1—ArcGIS Runtime SDK for iOS | ArcGIS for Developers however still very old to see the changes. I would recommend to upgrade to 10.2.4 as is currently in cocoapods and try to migrate from there. Hope the Release notes can help you.

Cheers

Al

View solution in original post

0 Kudos
2 Replies
AlPascual
Esri Contributor

2.1 is a very old SDK, we had many releases from 2.1 to 10.2 as you can see on the Product Life Cycle document:

http://downloads.esri.com/support/product%20life%20cycle/developers/ArcGISiOSSDK_PLC.pdf

SDK 10.2 October 29, 2013 October 2013 – March 2014

SDK 10.1.1 April 2013 X Retired

SDK 2.3.2 July 2012 X Retired

SDK 2.3 June 2012 X Retired

SDK 2.2.X Nov 2011 X Retired

SDK 2.1 July 2011 X Retired

The versions between are now retired, you can get release notes for 10.1.1 only Release notes for 10.1.1—ArcGIS Runtime SDK for iOS | ArcGIS for Developers however still very old to see the changes. I would recommend to upgrade to 10.2.4 as is currently in cocoapods and try to migrate from there. Hope the Release notes can help you.

Cheers

Al

View solution in original post

0 Kudos
JamesPower1
New Contributor II

I realize 2.1 is a very old SDK and want to move off of it ASAP. I am using the greedy operator with Cocoapods while developing so I am pointing to 10.2.4 at the moment (I'll point directly to the latest version once the release is complete).

Thanks for the information regarding the release notes. I have a feeling I'll be doing a lot of trial and error for awhile regarding the unavailable release notes

0 Kudos