custom tiled layer with wrong AGSTile infomation?

461
10
03-08-2012 07:29 PM
lynnwang
New Contributor II
hi,
   I'm work on the custom tiled layer sample and place a exploded tile folder in the app., the largest scale of which in the tiling scheme is about 1:250.
   When I browse the tiles on ipad,the tiles arrange regularly when the map scale is smaller 1:500???
   but if i browse to the last level,map scale is about 1:250,the tiles retured very abnormal. It looks like the new and wrong placed 1:500 tiles overlap the expanded 1:500 tiles i just browsed.
   I also set a breakpoint in the function  (NSOperation<AGSTileOperation>*) retrieveImageAsyncForTile:   (AGSTile *)  tile   {?????????}
   and found out the level property of the *tile is wrong.

   Has anyone met this problem before? And what's wrong with it?

  p.s. The tiles display normally  in Flex api.
   Here is the LOD infomation:
- <LODInfos xsi:type="typens:ArrayOfLODInfo">
- <LODInfo xsi:type="typens:LODInfo">
  <LevelID>0</LevelID>
  <Scale>2254.467762533835</Scale>
  <Resolution>5.3644181298506988e-006</Resolution>
  </LODInfo>
- <LODInfo xsi:type="typens:LODInfo">
  <LevelID>1</LevelID>
  <Scale>1128.4971760000001</Scale>
  <Resolution>2.6852150254815902e-006</Resolution>
  </LODInfo>
- <LODInfo xsi:type="typens:LODInfo">
  <LevelID>2</LevelID>
  <Scale>564.24858800000004</Scale>
  <Resolution>1.3426075127407951e-006</Resolution>
  </LODInfo>
- <LODInfo xsi:type="typens:LODInfo">
  <LevelID>3</LevelID>
  <Scale>282.12429400000002</Scale>
  <Resolution>6.7130375637039756e-007</Resolution>
  </LODInfo>
  </LODInfos>
0 Kudos
10 Replies
NimeshJarecha
Esri Regular Contributor
If possible, attach your cache here and I'll test it with sample and see what's going on.

However, why are you using custom tiled layer sample. You should use ArcGIS Local Tiled Layer.

Instead of .tpk you can create uncompressed .zip file which works with AGSLocalTiledLayer. Please make sure that the zip MUST be uncompressed zip. You can use utilities like 7-zip or on Mac command line 'zip' utility with store only mode (zip �??o).

Regards,
Nimesh
0 Kudos
lynnwang
New Contributor II
Hi, Nimesh!

    I uploaded the exploded tile folder as an attachment. you can have some tests.

    And what do you mean about the zip tile folder ? You mean zip file can also be loaded as a AGSLocalTiledlayer? And how can I organize this zip folder?


    lynnew,
    best regards
0 Kudos
lynnwang
New Contributor II
I speculate it probably because some parameters through the calculation do not have enough precision.
When the resolution is too small, AGSTile can not get right level,row,column.
0 Kudos
lynnwang
New Contributor II
Hi, Nimesh

   Is there any progress on this problem?
0 Kudos
NimeshJarecha
Esri Regular Contributor
Sorry for the late response.

You suspected right..though it turned out to be an issue in the AGSMapView and not in the sample. The AGSMapView was not handling that low resolution. It's been fix in the system and you won't see the same issue with the next version of the SDK release.

Thank you for reporting.

Regards,
Nimesh
0 Kudos
lynnwang
New Contributor II
Thank you for your response.
   Hope next version will be coming soon.
0 Kudos
NimeshJarecha
Esri Regular Contributor
Yes, very soon! Stay tuned 🙂

Regards,
Nimesh
0 Kudos
NimeshJarecha
Esri Regular Contributor
The new version (v2.2) of the ArcGIS Runtime SDK for iOS is released. Please see what's new in version 2.2.

Regards,
Nimesh
0 Kudos
RickJones
Occasional Contributor II
I'm curious if the new version fixed the problem before we upgrade.
I don't see this mentioned in the What's New.
0 Kudos