Can a ipad be used to develop using the SDK for iOS?

481
6
Jump to solution
05-23-2013 02:49 AM
paulvan_heerden
New Contributor
I work for a large forestry company, and am investigating a technology swap from using Trimble GPS devices to using iPhones. I am still in the early stages of the process. To test all possibilities, I have to develep apps using the SDK.

The hardware requirements are - "Intel-based Macintosh running Lion (OS X 10.7 or higher) or Mountain Lion (OS X 10.8 or higher) "

Would an iPad suffice, or do I need a Mac?
0 Kudos
1 Solution

Accepted Solutions
MichaelDavis3
Regular Contributor
There is an iOS simulator included with xCode that allows you to develop and test on a Mac without having access to an iPhone or iPad.

Having a machine running OSX is required for iOS development with the ESRI SDK.

View solution in original post

0 Kudos
6 Replies
paulvan_heerden
New Contributor
Anyone? I would like to do hardware purchasing, but I would rather buy an iPad than a Mac
0 Kudos
NimeshJarecha
Esri Regular Contributor
You need a Mac to start development/coding. You CANNOT do development/coding on iPad.

Regards,
Nimesh
0 Kudos
paulvan_heerden
New Contributor
You need a Mac to start development/coding. You CANNOT do development/coding on iPad.

Regards,
Nimesh


I was told that there might be some sort of OS simulator that I could use on iPad that will simulate the Mac environment. Is that incorrect?? Sorry for the noob question
0 Kudos
MichaelDavis3
Regular Contributor
There is an iOS simulator included with xCode that allows you to develop and test on a Mac without having access to an iPhone or iPad.

Having a machine running OSX is required for iOS development with the ESRI SDK.

View solution in original post

0 Kudos
paulvan_heerden
New Contributor
There is an iOS simulator included with xCode that allows you to develop and test on a Mac without having access to an iPhone or iPad.

Having a machine running OSX is required for iOS development with the ESRI SDK.


Thank you very much. I now know what to go out and purchase.
0 Kudos
BobbyRay
New Contributor
You do need a Mac OS X for creating/testing your iOS app. Xcode(SDK) will only work on Mac OS X. I don't think it will be possible on iPad.
0 Kudos