Apple Mach-O Linker (Id) Error's

2395
5
12-13-2011 01:31 AM
DanielGranger
New Contributor
Hi all,

Just installed ArcGIS for iOS API and go to run the MapViewDemo example and I get 4 fatal errors:

Undefined symbols for architecture i386:
  "_OBJC_CLASS_$_AGSTiledMapServiceLayer", referenced from:
      objc-class-ref in MapViewDemoViewController.o
  "_OBJC_CLASS_$_AGSDynamicMapServiceLayer", referenced from:
      objc-class-ref in MapViewDemoViewController.o
  "_OBJC_CLASS_$_AGSSpatialReference", referenced from:
      objc-class-ref in MapViewDemoViewController.o
  "_OBJC_CLASS_$_AGSEnvelope", referenced from:
      objc-class-ref in MapViewDemoViewController.o
ld: symbol(s) not found for architecture i386
clang: error: linker command failed with exit code 1 (use -v to see invocation)


Any Ideas?
0 Kudos
5 Replies
RickJones
Occasional Contributor II
Try removing the libArcGIS.a from the project, and re-adding it.
0 Kudos
PrasadJ
New Contributor II
Thank You once it remove and add it working fine. The application was build fine But I am not getting map on the simulator.
0 Kudos
NimeshJarecha
Esri Regular Contributor
Is your AGSMapView outlet is connected to "Map View"?

Reagards,
Nimesh
0 Kudos
PrasadJ
New Contributor II
Ya i have done.

Steps I have done:
1) Open xib file
2) Right Click on File'Owner and drag to View then it found View. I select View
3) Again Right Click on File Owner and Drag till Map View then i found mapView. I select MapView

I am new this development. so, Please provide the steps if any thing wrong.
0 Kudos
NimeshJarecha
Esri Regular Contributor
Here are the detail steps to Configuring an Xcode Project..

Hope this helps!

Regards,
Nimesh
0 Kudos