Simple iOS app does not work on device

386
2
Jump to solution
04-08-2020 12:35 PM
LORAMAdmin
New Contributor II

I am new to creating IOS apps and I can take a simple single page app without the Esri framework and load it onto an iPad mini. But, when I use the Esri framework either from the library or by using a pod file I can run the app successfully from the simulator and I can install the app on my device but it crashes once it is installed. I just did another test with the MapViewDemo-Swift and I can only see the title before the app aborts (Thread 1: SIGABRT).

I must be missing coming very simple. Can somebody point me in the right direction?

Tom

0 Kudos
1 Solution

Accepted Solutions
MarkDostal
Esri Contributor

Tom,

Sorry to hear you're having problems.  Take a look at the information here which fixes a similar issue.

If that does not fix your issue, please reply with the iOS version, Xcode version (and ideally a stack trace) and any other pertinent info and I can take a look.

Mark

View solution in original post

0 Kudos
2 Replies
MarkDostal
Esri Contributor

Tom,

Sorry to hear you're having problems.  Take a look at the information here which fixes a similar issue.

If that does not fix your issue, please reply with the iOS version, Xcode version (and ideally a stack trace) and any other pertinent info and I can take a look.

Mark

0 Kudos
thomasbales
Occasional Contributor

I made the schema changes as suggested from the above post, updated everything to iOS 13.4, change the build to legacy, moved the project file from iCloud to local and it now works.

Thanks for the response,

Tom