Download Rasters using Polygon

199
2
Jump to solution
12-15-2020 02:15 PM
JonathanPollack
New Contributor III

I am trying to use the Download Rasters operation with the polygon clip.  My output is the same as using Envelope (get a rectangle output).  Any idea what I am doing wrong?  Here is the command I am using.  I expected my output to look like a triangle as in the image below...  I am trying to re-create the "clip raster" tool functionality in ArcGIS Pro.

https://..../server/rest/services/Glendale_Imagery/June_2020_Color/ImageServer/download?rasterIds=390,391,397,398,545,553,555,556,557&geometry={"rings":[[[-12509589.410818882,3972455.151473253],[-12507238.972199116,3972053.8570747566],[-12509627.629333025,3971614.344162117],[-12509589.410818882,3972455.151473253]]],"spatialReference":{"wkid":3857}} 

 

JonathanPollack_0-1608070281566.png

 

 

 

Tags (1)
0 Kudos
1 Solution

Accepted Solutions
JohnGrayson
Esri Regular Contributor

Try adding a 'geometryType' parameter since the default value is envelope but you're trying to send a polygon instead:

geometryType=esriGeometryPolygon

Doc: Download Rasters 

View solution in original post

0 Kudos
2 Replies
JohnGrayson
Esri Regular Contributor

Try adding a 'geometryType' parameter since the default value is envelope but you're trying to send a polygon instead:

geometryType=esriGeometryPolygon

Doc: Download Rasters 

View solution in original post

0 Kudos
JonathanPollack
New Contributor III

Thanks, this helped

0 Kudos