Incomplete display of labels in MMPK in Quick Capture

293
2
Jump to solution
06-06-2021 08:12 AM
PetrSTASTNY
New Contributor II

In our Quick Capture projects, we use the Mobile Map Package (MMPK) as a base map. MMPK is generated from our routing geodatabase. There are certain areas in the geodatabase where all edges have the same attribute value (e.g. the maximum speed). If I add labels to edges in ArcGIS Pro, they will appear everywhere in the area mentioned above. However, if I display the same MMPK in Quick Capture, the labels will only appear somewhere. But we need them to appear wherever they are in the database.

Is there a solution to force MMPK to display labels just like in ArcGIS Pro? 

- Labeling of value 30km/h in ArcGIS Pro:

PetrSTASTNY_0-1622992329948.png

- And the same area in MMPK in Quick Capture:

PetrSTASTNY_1-1622992373121.png

We use Quick Capture 1.9.127 and ArcGIS Pro 2.8.0.

0 Kudos
1 Solution

Accepted Solutions
PeterDimitrov1
Esri Contributor

Hi PetrSTASTNY,

Here are a few things to check:

  1. Is remove duplicates enabled? This may be causing some of the labels to not be visible in QuickCapture.
  2. Another reason may be line connection - is it set to minimizeLabels or unambiguousLabels?

Also, are those street or line labels in Pro?

I will be interested to see what labeling properties are set in ArcGIS Pro prior to exporting the data - ideally, would you be able to share a Pro aprx project file with us to examine?


Kind Regards,
Peter Dimitrov

View solution in original post

2 Replies
PeterDimitrov1
Esri Contributor

Hi PetrSTASTNY,

Here are a few things to check:

  1. Is remove duplicates enabled? This may be causing some of the labels to not be visible in QuickCapture.
  2. Another reason may be line connection - is it set to minimizeLabels or unambiguousLabels?

Also, are those street or line labels in Pro?

I will be interested to see what labeling properties are set in ArcGIS Pro prior to exporting the data - ideally, would you be able to share a Pro aprx project file with us to examine?


Kind Regards,
Peter Dimitrov

View solution in original post

PetrSTASTNY
New Contributor II

Hi Peter

Thank you a lot! The right option was: Line connection - One label per feature

0 Kudos