Unable to load ArcGIS.Desktop.xxxxx namespaces in v2.5

171
2
Jump to solution
02-09-2020 07:53 PM
SreenivasaRaoPigili
Occasional Contributor

Hi Team,

    We have developed a solution on v2.4 and which was working very good. I have updated to v2.5 and from then i am facing below errors.

When i checked in my installation directory(C:\Program Files\ArcGIS\Pro\bin)  - i am able to find these dlls (with 01/14/2020 date.)

Is there anything else - we have to do the configurations. Please help me.

FYI: Still same solution is working properly on ArcGIS Pro v2.4.

0 Kudos
1 Solution

Accepted Solutions
Wolf
by Esri Regular Contributor
Esri Regular Contributor

ArcGIS Pro 2.5 requires the .Net Framework 4.8.  Once you change the target framework of your project to 4.8, the errors are resolved.  Details are documented here: https://github.com/esri/arcgis-pro-sdk#requirements

View solution in original post

2 Replies
KokiKUNIHARA
New Contributor II

Hello SreenivasaRao!

Have you done this yet? If you haven't, I think this is causing the trouble.

How To: Convert a version 2.0 to 2.4 ArcGIS Pro SDK add-in solution to Pro 2.5 and later versions 

Wolf
by Esri Regular Contributor
Esri Regular Contributor

ArcGIS Pro 2.5 requires the .Net Framework 4.8.  Once you change the target framework of your project to 4.8, the errors are resolved.  Details are documented here: https://github.com/esri/arcgis-pro-sdk#requirements

View solution in original post