The tooltip heading in the button palette doesn't update when I change to a different tool.

144
1
Jump to solution
01-07-2020 12:40 PM
AnandhaSudhan
New Contributor II

The tooltip heading in the button palette doesn't update when I change to a different tool. For example, 

I have 3 different buttons with their own caption and tooltips. 

Below is sample code for reference:

<buttonPalette id="CustomPalette" caption="Custom buttons" extendedCaption="Open custom buttons palette" dropDown="false" menuStyle="true" showItemCaption="1">
<button refID="A"/>
<button refID="B" />
<button refID="C" />
</buttonPalette>

<button id="A" caption="Button A" >
<tooltip heading="Button A">
Tooltip for Button A.<disabledText /></tooltip>
<content group="Custom" />
</button>‍‍‍‍‍‍‍‍‍‍‍

<button id="B" caption="Button B" >
<tooltip heading="Button B">
Tooltip for Button B.<disabledText /></tooltip>
<content group="Custom" />
</button>‍‍‍‍‍‍‍‍‍‍‍

Initially, when I scroll over button A, it displays the correct tooltip heading ("Button A") and tooltip("Tooltip for Button A"). 

But, when I switch to tool B by clicking on button B in the palette, the tooltip gets updated accordingly (Tooltip for Button B") but the tooltip heading still reads "Button A" instead of "Button B". Is this an existing bug in the SDK?

I tried changing all options in the buttonPalette control. Changed showItemStyle to 0,1,true, false. No luck.

Any help would be greatly appreciated. Thank you!

0 Kudos
1 Solution

Accepted Solutions
AnandhaSudhan
New Contributor II

Solved. Had to change menuStyle to false. It seems to work now but it stills seems like a bug when menuStyle is set to true.

View solution in original post

0 Kudos
1 Reply
AnandhaSudhan
New Contributor II

Solved. Had to change menuStyle to false. It seems to work now but it stills seems like a bug when menuStyle is set to true.

View solution in original post

0 Kudos