Wrong selection count when using Select by Location on WFS layer

11-18-2020 01:57 AM
Labels (1)
New Contributor II

I have several WFS layers loaded into the map using ArcGIS Pro 2.5.


This is one of the WFS URL:


Access to the shapefile of the dataset:



When I run select layer by location between the WFS layer and the AOI attached, I get 0 count.

However, when I run the same selection using the shapefile, I get 49 selected features.


Screenshot 2020-11-18 171709.jpg


Here is another WFS layer:


Access to the shapefile of the dataset:


Similarly, I am expecting 58 selected features, but only 34 features were selected from the WFS layer. 

Screenshot 2020-11-18 172528.jpg


I tried other tools such as Clip but I still get inconsistent results.

I believe the issue is related to the 'Set the maximum features returned' property. The number selected features from the select by location increased when the max features value is increased. 

I need to perform this spatial query on WFS layers regularly. The source of the WFS and the size of the AOI may be different each time. Ultimately, I want to automate this workflow using arcpy. 

How can I get consistent results without having to play with the max features returned value?




Tags (2)
0 Kudos
1 Reply
New Contributor II

Just a thought. Can I update the WFS BBOX using arcpy?

0 Kudos