WMS layer doesn't display in ArcGIS Pro

1626
2
09-04-2017 05:23 AM
TheodoreF
Occasional Contributor II

ArcGIS Pro 2.0.1 trial

Possible glitch with adding sublayers of a WMS manually?

In a new project, I've followed the steps to add a new WMS layer to the map. For this example I'm using BGS 50K geology: https://map.bgs.ac.uk/arcgis/services/BGS_Detailed_Geology/MapServer/WMSServer 

Insert>Connections>New WMS Server> paste the URL into the box and click ok

then, Map>Add Data>Data> browse to the WMS server layer and click ok to add to the map.

The WMS layer (and sublayers) display properly with the settings like this:

But if I change the option here to add the sublayers manually, the WMS layer doesn't display (see the white background):

If I then try to rectify this by reverting to 'include all groups and layers', it still doesn't display and I have to add the WMS layer to the map again.

There are no display scales on the layer and I haven't moved around in the map between changing the option.

Tags (2)
2 Replies
SteveKloiber
New Contributor II

I had something similar occur. I'm not sure what's going on. I tried one imagery service and it didn't work. This service had multiple layers. However, I added an imagery service using a layer file that only had one layer in it and that drew fine. One other difference was the format of the service. The one that worked used a REST endpoint. The one that didn't used some other kind of configuration.

This is the one that didn't work - http://geoint.lmic.state.mn.us/cgi-bin/wms?

SteveKloiber
New Contributor II

I did find a work around. I loaded the WMS into ArcMap (which has always rendered this service just fine). I created a layer file for the service and then added the service using this layer file. The WMS worked fine this way. But if I tried to add it directly as a WMS service in ArcGIS Pro, it won't render at all.