Why do disabled WMS service layers still show up in the legend when map is exported?

112
2
Jump to solution
05-20-2020 12:33 PM
MathesSilas
New Contributor II

I'm using some WMS service layers in ArcGIS Pro version 2.5.1.  I can turn off the WMS layers in the table of contents and the legend, and they appear to be correctly removed from the legend in the layout.  However, when I export my map to a PDF the WMS service layers appear in the legend.

Is there a workaround for this, other than converting the legend to graphics? 

Tags (2)
Reply
0 Kudos
1 Solution

Accepted Solutions
KoryKramer
Community Moderator

This would be best in the ArcGIS Pro‌ space.

I realize this is frustrating, but it sounds like you're running into [BUG-000130800: Printed layouts generated in ArcGIS Pro 2.5.1 include their Web Map Services (WMS) in legends even if the legend item is deactivated in the Contents pane.]

It's new enough that it doesn't appear to be published yet to support.esri.com, so if you need to be attached, please contact Technical Support.

The listed workaround is: "Remove the legend entry for the WMS by deactivating the New layer option under Synchronize with map. Please note: it remains unclear whether this has broader implications."

Hope this helps!

View solution in original post

2 Replies
KoryKramer
Community Moderator

This would be best in the ArcGIS Pro‌ space.

I realize this is frustrating, but it sounds like you're running into [BUG-000130800: Printed layouts generated in ArcGIS Pro 2.5.1 include their Web Map Services (WMS) in legends even if the legend item is deactivated in the Contents pane.]

It's new enough that it doesn't appear to be published yet to support.esri.com, so if you need to be attached, please contact Technical Support.

The listed workaround is: "Remove the legend entry for the WMS by deactivating the New layer option under Synchronize with map. Please note: it remains unclear whether this has broader implications."

Hope this helps!

View solution in original post

MathesSilas
New Contributor II

Thanks for the quick answer, Kory.  I must have missed the ArcGIS Pro space--I'll try to move it there if possible.

Reply
0 Kudos