Why are sun shadow volume multipatches detached from input buildings?

03-03-2017 03:47 AM
Occasional Contributor III

I am trying to generate a multipatch of the shadow volume created by a building at a particular moment in time. However, when I use the "Sun Shadow Volume" tool, the output multipatch is detached from the input building (and sometimes it is also tilted such that if I were to follow it with straight lines it would not match up to the building). I am using ArcGIS Pro (I also tried it in ArcGIS Desktop - same story - so let's stick to Pro). Does anyone know how to solve this?

As an input I am using a building multipatch obtained by extruding a polygon using the height values found in the attribute table and converted to multipatch. For the conversion into multipatch I tried using both the "Layer 3D to Feature Class" tool as well as the "Feature to 3D by Attribute" tool. The results are the same, both in the creation of the multipatch, as well as in the execution of the "Sun Shadow Volume" tool.

I am executing the "Sun Shadow Volume" tool for 1 March 2017. When I run the tool for 10:00:00 AM or 11:00:00 AM, the output shadow volume multipatch is detached from the building:

However, when I run the tool for 12:00:00 PM, it works just fine:

For reference, these are the input parameters used for the execution of the tool:

(Date is in US format; the building is in Italy, so it follows the "Central_Europe_Standard_Time" zone).

Additional info:

Input and data frame projected coordinate system: WGS 1984 UTM Zone 32N

0 Replies